Skip navigation

Sound not smooth (jerky) in Athlon64 Dual core PC

Forum NavigationHome > Forum Index > Longbow Support > Sound not smooth (jerky) in Athlon64 Dual core PC
Level 14 Human gamer
Alignment: True neutral
Posted on August 28, 2006 at 10:20 am

When I change my PC to Athlon64 dual core, Rivalball sounds very jerky.

I've already set it to CPU 0 using SysInternal's Process Explorer but can't help, please provide a solution.

Thanks.

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on August 28, 2006 at 1:00 pm

First, make sure you don't have a lot of other programs running in the background when you're playing Rival Ball.

If you have an anti-virus scanner, you might want to try turning it off while you play; sometimes a virus scanner can eat up a lot of resources and show down your game.

You could also try running the game in compatibility mode. To do that, right-click on the shortcut you usually use to launch the game, choose the 'Compatibility' tab, then check the box to run the game in Windows 98 compatibility mode.

Let me know if you're still having trouble.

Level 14 Human gamer
Alignment: True neutral
Posted on August 29, 2006 at 9:06 am

First, make sure you don't have a lot of other programs running in the background when you're playing Rival Ball.

If you have an anti-virus scanner, you might want to try turning it off while you play; sometimes a virus scanner can eat up a lot of resources and show down your game.

You could also try running the game in compatibility mode. To do that, right-click on the shortcut you usually use to launch the game, choose the 'Compatibility' tab, then check the box to run the game in Windows 98 compatibility mode.

Let me know if you're still having trouble.


Still jerky.

1) Virus scanner turned off
2) set to compatibility mode [win98/me]

Another game have this problem too (Serious Sam 2), but it have some work around. I hear AMD CPU driver change the timing, so it's faster but cause some timing problem.

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on August 29, 2006 at 4:25 pm

I don't think it's actually the CPU that's at fault; we've tested the game on the AMD Athalon64 X2 Dual Core without any issues.

Okay, here's a few more things you can try:
* Do you have the latest sound drivers installed for your machine? If you don't know where to get them, let me know the make and model of your computer or, if you know them, the make and model of your sound card or motherboard.
* Do you have any programs running in the background that may be using sound? In particular, pay attention to all the programs running in your system tray; that's the little tray on the bottom-right of your screen beside your clock with all the icons. You can try closing some of those by right-clicking on them and choosing 'Exit' or 'Quit' (it depends on the program).
* You might also want to run an adware scan. You can get a free adware scanner here.

Level 14 Human Shadow
Alignment: Chaotic good
Location: Earth Orbit, Preparing to Attack
Posted on August 29, 2006 at 11:17 pm

Pop open Task Manager (right-click next to your start menu and select Task Manager). Go to the Processes tab. Sort by CPU usage. See if you can identify anything that's hogging CPU.

Next, while in Task Manager, switch to the Performance Tab. How much Memory are you using? (what you want is the MEM Usage from the graph). How much memory do you have installed? (You can get this from Physical Memory (Total) below the graph.)

My guess is one of two things:
1: You've got an application hogging system resources, or
2: You don't have enough memory on the system. Even the fastest systems choke when you have too little memory.

--RC