Skip navigation

Hegemony Gold problem : general stuck in the sea

Forum NavigationHome > Forum Index > Hegemony > Hegemony Gold problem : general stuck in the sea
Level 4 Human gamer
Alignment: True neutral
Posted on August 8, 2015 at 12:41 pm

Hi all

I have this problem, I was disembarking a phalangite brigade from a ship, the ship was attacked by enemies and routed to his home city; the phalangite brigade landed succesfully, but their general detached from the unit and remained stuck in the middle of the sea, where his ship was attacked

I tried to put a ship close to him, but says too far from land, I've tried to use the console commands, I've seen there is command attachleader, but I can't figure how to use it, it says always syntax error or unable to find brigade or similar

isn't there a way using console to teleport him somewhere? or to defeat him so that he can appear in his homecity to recover

see image


Level 8 Human gamer
Alignment: Lawful good
Location: German-speaking part of Europe
Posted on August 11, 2015 at 10:22 pm

If it is just barely outside of walkable terrain, try sending a trireme near him into shallow water, then trying to make him embark, possibly using the strategic map (where the trireme is much bigger comparatively) to find a sweet spot where the trireme is near him, but you are still able to click at it. Commands are invalidated by the terrain the mouse cursor is under, so an embark command can be both acceptable and non acceptable depending on where you click the target unit.