Skip navigation

Rome stuttering zoom and scrolling

Forum NavigationHome > Forum Index > Hegemony > Rome stuttering zoom and scrolling
Level 8 Human gamer
Alignment: Chaotic good
Location: Germany
Posted on May 27, 2015 at 7:43 pm

The game runs smooth on my PC except for one condition - the cursor and zooming stutter as hell. The units and the animations run smooth, only those two functions annoyingly stutter.
Is there anything I can do? It is really annoying.

Level 16 Extraplanar gamer
Alignment: True neutral
Posted on May 28, 2015 at 2:03 pm

Thanks for the report. Just to clarify, the cursor stutters just when moving around the screen when the camera is stationary? Can you tell if the stutters happen when the mouse moves over an object like a city or building or is the stuttering more random?

With the zoom stutter, does it get better as you play longer or does it remain consistent? Have you tried lowering the texture or sound detail and does that make any difference?

Unfortunately performance issues are often hard to reproduce because they depend a lot on a particular configuration, but hopefully with a little more info I might be able to make some improvements.

Level 8 Human gamer
Alignment: Chaotic good
Location: Germany
Posted on May 28, 2015 at 2:42 pm

1) To clarify: The mouse cursor does not really stutter, it just moves so slow and a short time after I moved the mouse (I miss the right word). This ist a permanent phnomena, whether the camera is stationary or moving and whatever the cursor moves on.

2) Moving the camera does stutter, as does scrolling.

3) Lowering the Graphic Settings from highest to lowest brought minimal improvement. I will try the sound setting.

4) It seems to be worst right at the beginning and to get sightly better after after that, but that might be just my imagination after you mentioned it.

Level 6 Human gamer
Alignment: Lawful good
Location: German-speaking part of Europe
Posted on May 28, 2015 at 4:19 pm

Delayed might be the word you're looking for.

I have the same issues.

Level 8 Human gamer
Alignment: Chaotic good
Location: Germany
Posted on May 28, 2015 at 5:10 pm

Delayed might be the word you're looking for.
Thank you, it was.

Level 16 Extraplanar gamer
Alignment: True neutral
Posted on May 28, 2015 at 6:34 pm

Thanks for the clarifications. The mouse issue sounds a little like a video card problem we had a long time ago in Gold where the video card was buffering a few frames causing a delay between when you move the mouse and when you see it move. We made some changes in Gold (which are also in Rome) to limit this but I will take a look at it again. It could be worth checking if there are any buffering related settings on your video card as well.

The zoom stuttering sounds like there are delays loading the games resources from the disk (sounds & images). These are usually worse at the beginning and get better as the game plays and fewer resources need to be loaded. The quickest fix for this is lowering the sound detail which reduces the number of sound files loaded during play. However, we have made a few specific improvements to resource loading in Hegemony III and I think some might be able to be ported back to Rome so I will look into that for the next Rome update.

Level 16 Extraplanar gamer
Alignment: True neutral
Posted on May 29, 2015 at 3:11 am

There's a new 2.2.2 release candidate up in the Steam 'update_testing' branch that may improve some of the stuttering you're seeing. It's revision 35426 and includes some changes we made for the new game to help reduce delays when the game loads new image or sound assets during play.

Unfortunately I wasn't able to reproduce the mouse delay you're talking about even when forcing triple buffering using the video cards settings. I will continue to look into it, but at least for the moment I don't have any more suggestions on that one.

Level 8 Human gamer
Alignment: Chaotic good
Location: Germany
Posted on May 30, 2015 at 9:32 am

I got the update and didn't notice any improvement.
But I played a bit with the settings, and although changes to thegraphic or sound settings did not help, the problem was improved by highering the double-click-delay number.
Somehow that stopped the cursor to delay and the stuttering seems to be better/ much less now. I will retry the game now and see, if that improvement lasts :)

Edit: I tried restarting everything and the improvement last, it still needs to be seen though whether prolonged playing will worsen it again.

Level 16 Extraplanar gamer
Alignment: True neutral
Posted on May 30, 2015 at 7:38 pm

Thanks for the feedback. Do you know what kind of video card/processor you have? As I said I can't seem to reproduce the problems on my machine, but maybe I can find something similar to yours. Also, do you encounter the problems with a new game or are you usually playing from an existing savegame?

Level 8 Human gamer
Alignment: Chaotic good
Location: Germany
Posted on May 31, 2015 at 6:45 pm

My video card is a NVidia Geforce GT 540M, my Processor U├Źnterl Core i5-480M,
The Problem occurred with new games and loaded savegames alike.