Skip navigation

Hegemony Rome and AMD

Forum NavigationHome > Forum Index > Hegemony > Hegemony Rome and AMD
Level 6 Human gamer
Alignment: True neutral
Posted on June 4, 2014 at 10:35 pm

I'm raising this subject in its separate thread.

I have an AMD Radeon HD 8760. The game is kinda stuttering at certain points. There's even occasional stutter on the panoramic background on the main game startup screen.

I tested the FPS. I'm sometimes down to 10 when paused and zoomed in on an army or town. At times, the game flows nicely enough at ca 30 FPS though, which is still very low. I even tried turning down detail to just high, turn off antialias and so on. My heavily graphics modded Skyrim does a steady 50-60 on Ultra as comparison.

Is there a problem with AMD cards? I've heard nothing of this sort from Nvidia owners.

Level 9 Human Truffle Farmer
Alignment: Good
Location: Australia
Posted on June 5, 2014 at 8:28 am

I can second this. I don't believe my card is nearly as powerful but I had the same problem. I reported some of it during the beta and the problem has been ongoing.

I can confirm that my card is working perfectly (since it has just been replaced) and the drivers are current. To my knowledge there was never a part of Hegemony: Gold that suffered in the same fashion.

Level 6 Human gamer
Alignment: True neutral
Posted on June 5, 2014 at 5:56 pm

I've got a Nvidia GTX 770 and the only real stutter/delay I've noticed is on the opening screen as the POV overflies the terrain. The earlier builds did suffer from stutter, but the latter ones haven't been an issue that I've noticed.

Now if I could only get Norton AV to STOP flagging the game EXE as a Trojan and quarantining it... :)

Level 6 Human gamer
Alignment: True neutral
Posted on June 7, 2014 at 2:13 am

Wow, you use Norton? Try Malwarebytes Anti-malware, best ever. Norton is BLOAT

Level 6 Human gamer
Alignment: True neutral
Posted on June 19, 2014 at 12:21 pm

There was a big update last night obviously a beta patch. I haven't seen any patch notes, but I tested it out to see how the AMD problem is. Win8, i5-3350P (Quad @ 3.10GHz), 16GB RAM, AMD Radeon HD 8760 (2GB) with latest 14.4 driver.

I tried the game out for an hour or so to check whether the AMD problems had been resolved. There's still stutter on the main menu screen. At one point, when I was paused on the zoomed out strategic map and zoomed in on a mine, my FPS dropped to about 15 and stayed there. It resolved itself when I unpaused and I was doing a steady 30 on zoomed in tactical, with 60 zoomed out to the strategic map.

The game is playable, no doubt about it, but the weird FPS drops and stutter on the main menu are still there. I'll test it out some more this evening. I really like how the new coloured borders look!

Level 6 Human gamer
Alignment: True neutral
Posted on August 18, 2014 at 9:59 pm

TEsting the latest beta patch now...

Some performance improvements. I had a steady 30-40 FPS during the battle against Ariovistus' Horde and there's a lot of units on-screen then, so that was good. Still some stutter on the main menu screen.

Now here's the weird thing. I left my game idle, paused and zoomed in on a city and then went outside for a while. When I came back in, the FPS was down at 9. Yes 9. It got back up to 60 after a couple of seconds unpaused and zoomed out. What's up with that behaviour?