Skip navigation

Performance / Optimizations?

Forum NavigationHome > Forum Index > Longbow Support > Performance / Optimizations?
Level 5 Human gamer
Alignment: True neutral
Posted on May 20, 2014 at 7:23 pm

(Copy / Pasted from the Steam forum)

Just purchased the game and tried it out, but I was wondering if there were any immediate plans to improve performance? Or if there are any performance / .ini tweaks that can be made?

I'm running it on a Windows 8.1 64bit Laptop with an i7 2.2Ghz + 8GB Ram + 2GB Radeon GPU - which runs CIV 5 at max settings just fine at 1920x1200 resolution. But unfortunately Hegemony is suffering from bad mouse lag (I've tried all the available settings to fix it, to no avail) and the game in generally runs really slow (unsmooth scrolling / zooming and the mouse lag problem makes it unplayable) - I've tried running at Lowest settings and a low resolution, but nothing helps. I have the latest drivers and all the usual stuff.

Are there any tips to optimize the game? Or should I basically just wait for more patch updates to roll out and hope that it improves the game performance?

Regards,

Andy

P.S. Here's my DXDiag, and I notice this in it, not sure if it's a problem: http://ge.tt/1ZZmoWh1/v/0?c

---------------
Diagnostics
---------------

Windows Error Reporting:
+++ WER0 +++:
Fault bucket 94538808244, type 5

Event Name: RADAR_PRE_LEAK_64

Response: Not available

Cab Id: 0

Problem signature:

P1: Hegemony Rome.exe

P2: 2.0.1.0

P3: 6.3.9600.2.0.0

Level 13 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on May 20, 2014 at 10:40 pm

(Copy / Pasted from the Steam forum)

I'm not sure what's wrong with your dxdiag; I've never seen it do that before. Can I assume you have your latest drivers installed?

As far as optimizations go, one easy thing to do is defrag your drive. Some of the lag comes from simply trying to load assets off of the drive.

Another easy improvement and fairly dramatic improvement is to go into the advanced graphics settings and change to the low-detail terrain. This reduces the detail a little bit, but makes quite a difference in performance. This is literally the only way we were able to get the game to run in the memory limits of 32-bit machines, and it can still be useful on 64-bit machines, especially laptops which might have some funny shared memory configurations.

Another thing to try is turning down the vegetation detail. We saw a performance problem with the vegetation on one of our laptops.

You can also try playing with the settings file. If you're not sure where your settings file is, see here. There's also a SafeSettings.xml file in the game directory that shows some hidden settings; you'll have to copy these into your personal settings file if you want to use them.

Some of those settings are for the new multi-threaded sound engine. Most computers nowadays have a lot of cores to spare, so the sound engine doesn't tend to induce any stutter (any more), but If your computer doesn't have many cores and you have a lot of memory to spare, you can try doubling the ogg cache (which will reduce hard drive fetches) or trippling the wav cache (which will reduce ogg decompression). You can also just try turning the sound off to diagnose whether or not the sound engine is causing lag.

Level 5 Human gamer
Alignment: True neutral
Posted on May 20, 2014 at 10:44 pm

Thanks for the reply Rick,

I do have the latest drivers installed for everything.

I forgot to mention I run an SSD hard drive.

The main problem I have is the unresponsive mouse - it lags behind actual movement - is anyone else experiencing this problem? Makes it hard to select unit / buttons / options.

I'll try those tweaks / suggestions though and see what happens.

Thanks again!

Level 13 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on May 21, 2014 at 1:54 am

Ah, maybe it's not your hard drive access, then.

Usually when your mouse appears to lag, it's just because you're experiencing a low frame rate. Hegemony doesn't use any fancy hardware cursors, so when you're experiencing low frame rates, it also affects your cursor. The easiest way to measure your frame rate is to install a program that displays a frame rate counter, like Fraps.

However, sometimes lag is the result of the "flip queue" (or "pre-rendered frames", as nVidia calls it). This happens when your CPU is much faster than your GPU, and can queue up several frames, which makes it appear as though you have a high frame rate, but by the time the frames are drawn, they're old.

We fixed this for most users years ago by simply limiting the FPS to 60, but you can try lowering the FPS cap to see if that helps. We don't have a setting for this in-game, but in the SafeSettings.xml file you'll see a setting called "FpsLimit" which you can play with.

Alternatively, you can install a program called "RadeonPro", which lets you modify how big your flip queue is. Turning it down to 0 should reduce lag. NB: I've never tried this program.

Level 5 Human gamer
Alignment: True neutral
Posted on May 21, 2014 at 3:33 am

Thanks again Rick,

When I have some time I'll run some tweaks and tests. Appreciate the help!

Level 8 Human gamer
Alignment: True neutral
Posted on May 26, 2014 at 7:55 am

I've also encountered the problems with mouse lag and low FPS (15-17). For me it happens when I have alt+tabbed out of the game and back in.
I can fix this by quitting the game and reloading it, then I'm back at a steady 60 FPS. Though this is a bit of a pain, as it takes a while to load.