Skip navigation

Hegemony Rome - Sound issues since patch

Forum NavigationHome > Forum Index > Longbow Support > Hegemony Rome - Sound issues since patch
Level 4 Human gamer
Alignment: True neutral
Posted on May 16, 2014 at 12:13 am

Hi guys!

So long story short my game worked absolutely perfectly until the patch that was released tonight to coincide with release.

I own a Asus Xonar DS soundcard and it would seem that since the patch and the "new sound engine" have been introduced the sounds for things like "trotting" and "feet marching" for units do not play correctly ... they seem to be cutting themselves off or being played backwards.

I sent an email to Kalypso support but I see Rick answering a ton of questions and I am hopeful that I will get a more solid answer here.


I am running the absolute latest drivers for the Asus Xonar (there are very few) and I am confident the issue lies with the new sound engine.

Ironically the issues and symptoms the patch notes state the new engine was meant to remedy were never an issue for me ... please help me I bought the game yesterday and it worked flawlessly even as an early access client .... tonight it gets released and the sound is in an unbeareable state :(

Level 4 Human gamer
Alignment: True neutral
Posted on May 16, 2014 at 4:06 pm

You guys are prolly all off for the weekend now and I am stuck with a game I cannot enjoy :(

However, I have done testing of my own and come to the following conclusions.

Having gone into the "sound" folder and tested playback of many files using various players, I am pretty sure that the issues lies with playback and looping ... for example a "marching" sound of the units is produced by looping the same sound files over repeatedly - the problem is that it seems to be cutting itself before the file finishes playback and/or looping too quickly ... the result is a sound that is just annoying rather than sounding anything like marching.

You can hear the same during combat ... the "chink" of swords hitting swords cuts itself off and noises from the men also cut-out before playback is fully finished.

This is hugely frustrating because prior to the patch and this new sound engine the game worked flawlessly for me and I was thoroughly enjoying it.