Skip navigation

"An error occurred while running Hegemony. Could not lock vertex buffer. (Err: -2147467259, Resource:)".

Forum NavigationHome > Forum Index > Longbow Support > "An error occurred while running Hegemony. Could not lock vertex buffer. (Err: -2147467259, Resource:)".
Level 9 Human gamer
Alignment: True neutral
Posted on February 16, 2014 at 6:05 am

When trying to start Hegemony GOLD from STEAM, the game loads normally. Then, when the game is about to start, I get a CTD with the following message: "An error occurred while running Hegemony. Could not lock vertex buffer. (Err: -2147467259, Resource:)".

My computer:

"Two 'NVIDIA GeForce TITAN's in SLI. (Latest drivers.)
32GB RAM.
'Intel Core i7-3960X'.
64-BIT 'Windows 7 Ultimate'.
'Creative SB X-FI Titanium'. (Latest drivers.)"

I've tried verifying the game cache, reinstalling on different hard-drives, (both SSD, and regular.), and launching the game in Administrator. No difference.

I have E-mailed you the dump-file, with a copy-pasted description.

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on March 4, 2014 at 7:40 pm

If you've emailed us, then we've probably already answered you, but I'll respond here as well for anybody else experiencing this problem.

Usually this is because your GPU has been configured to force anti-aliasing. We have some textures in the game that are sized to the screen, and when you force the game to apply full-screen anti-aliasing, those textures get huge, and your video card runs out of memory.

If you go into your nVidia Control Panel (or Catalyst Control Centre for ATI users) and change your anti-aliasing settings to "Application Controlled", this should solve your problem.

Level 5 Human gamer
Alignment: True neutral
Posted on July 9, 2014 at 6:42 pm

Same issue for me, unfortunately. I have fiddled with various settings in the nVidia control panel, including AA as suggested, to no avail. I'm running an i7 2.3 GHz, with a 670M, latest drivers.

Note this is also for Hegemony Gold, Greece.

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on July 9, 2014 at 8:39 pm

That's odd. Usually turning the AA off solves it.

You could always try turning down the resolution to see if that helps.