Skip navigation

Sluggish Mouse

Forum NavigationHome > Forum Index > Hegemony > Sluggish Mouse
Level 8 Human gamer
Alignment: Lawful good
Posted on February 5, 2014 at 3:29 pm

I am not sure if this is due to my system or if you are still optimizing graphics and game speed, so I am just going to say something. If it's being worked on or if my system is too slow just ignore me :)

On default graphics I would say that overall gamespeed while scrolling, zooming etc is average on my system and well playable in general. However the mouse cursor always feels kind of sluggish. I tried reducing graphics from default (while aware that this is not really supported yet) and the only thing that got the mouse to move even close to normal speed was switching the shadows to off. Since this helped a little the problem may be due to my hardware.
However while I definetly would say that frames and gamespeed are at a very playable level on default settings, the sluggish mousecursor is really annoying especially in engagements with multiple units since it is always lagging behind my movements and therefore hard to place. Is there any way to "disconnect" the cursor from the "graphics- or gamespeed" or something so that it behaves normally like on the desktop?

Win7, mobile i7 2.3 quad with Nvidia 650GT and 8 GB ram

Level 17 Extraplanar gamer
Alignment: True neutral
Posted on February 6, 2014 at 12:13 am

Thanks for the report. We've definitely still got a lot of optimization work to do still, but I'm surprised your lag is that bad given your specs. My dev machine is virtually identical and feels pretty responsive.

Do you have anything that can display your framerate like Fraps? And do you know if you have any overrides set on your video card like forced anti-aliasing? I know we had some problems with the original Hegemony where the video card would buffer a couple of frames which did produce some noticeable lag.

Level 8 Human gamer
Alignment: Lawful good
Posted on February 6, 2014 at 6:12 am

I do remember the problem from the original Hegemony too. But I am pretty sure that I only noticed it there in the menĂ¼ and in the first few steps of the tutorial. The rest was usually ok. I'll check the framerate and Video card overrides and get back to you.

Level 9 Human Truffle Farmer
Alignment: Good
Location: Australia
Posted on February 6, 2014 at 6:59 am

I only noticed the mouse lag in the Rome main menu too. But it appears to have mostly cleared up of late; ever since they fixed the weird menu display issue.

Level 8 Human gamer
Alignment: Lawful good
Posted on February 6, 2014 at 7:56 am

Ok I got the solution and everything is great now. I did not think of checking the nvidia panel because I know that I have most settings there inactiv or set to application anyway. I gave Rome special settings and went through the few that were "on" and everything worked great which at first confused me until I thought of checking which graphics processor the game was using. Apparently Rome defaulted to the integrated Intel chip. I did not even think of that because I wouldnt have expected it to run at all if that was the case and it actually ran so ok that I did not even notice (except for the mouse).
So now its set to use the Nvidia card and everything is as it should be. Sry for not thinking of that earlier... I just excluded that possibility because I wouldnt have expected a current game to launch at all on integrated graphics, much less run at an ok-ish speed.