Skip navigation

Could not lock vertex buffer. Err:80004005

Forum NavigationHome > Forum Index > Hegemony > Could not lock vertex buffer. Err:80004005
Level 17 Extraplanar gamer
Alignment: True neutral
Posted on January 9, 2014 at 5:34 pm

A number of users have reported a crash error while the game is loading with a message 'Could not lock vertex buffer: Err 80004005'. We've haven't encountered this in our internal testing and so it appears to be related to certain hardware configurations. For now I can only suggest updating DirectX or your video drivers. We're looking into this now and will hopefully have a solution shortly. I'll post again when we know more. Thanks for your patience.

Level 17 Extraplanar gamer
Alignment: True neutral
Posted on January 9, 2014 at 11:58 pm

I'm not sure if this will help, but I've updated the steam build so that it now installs the applicable libraries (VC 2013 & DirectX) when the game starts. For those who want to try this out, you may need to quit steam and re-open it in order to force Rome to update.

Level 7 Human Master & Commander, HMS Spitfire
Alignment: Lawful
Location: N. Atlantic, 1793
Posted on January 10, 2014 at 4:34 am

Rob:

I updated the video driver, did Windows update, and updated Rome on Steam. I'm experiencing the same error.

Level 5 Human gamer
Alignment: True neutral
Posted on January 10, 2014 at 3:48 pm

I am afraid that I am still experiencing the error, just one question could this be because of running of Windows 8.1?
I do know that there was a Nvidia driver update 2 days ago which I have previously updated to. I cannot seem to find any other reason why it shouldn't be working.

Level 8 Human gamer
Alignment: Chaotic evil
Posted on January 10, 2014 at 4:57 pm

My pc is running on:

Duo Core 2.66 Ghz
2 GB of ram
(still running on 64 bit)

and i am having this problem,even after all driver updates.

I had to downgrade recently, and there is a chance tomorrow i will upgrade again, on Quad Core and 4gb of ram.

I will post again, in case this specific problem arises again....

It's too bad i can't play it, from what i have read it must be amazing.

Level 17 Extraplanar gamer
Alignment: True neutral
Posted on January 10, 2014 at 7:26 pm

Thanks for trying. The DirectX thing was a bit of a long shot, but worth a try. At the moment our best guess is that it's an nVidia vs ATI issue. Most people who are experiencing the problem are running some version of an nVidia GTX card where as it seems to be working for those with Radeon cards. Here in the office we have mostly Radeons with one older nVidia card that hasn't had any issues.

Thanks for your patience, I'll post again as soon as I know more.

Level 17 Extraplanar gamer
Alignment: True neutral
Posted on January 10, 2014 at 8:43 pm

Progress! I just picked up a new nVidia GTX 650 ti card and was able to duplicate the crash. I haven't tracked down the cause yet, but things should go much faster now that I can replicate the problem.

The other good news is that, at least on my machine, the game does still work in windowed mode. Since you can't get to the options screen, you'll need to alter the settings file directly. The file is located in your "user/app data/roaming/Longbow Digital Arts/Hegemony Rome" folder. Open the 'settings.xml' file in a text editor and change the line that says "<windowed>false</windowed>" to read "<windowed>true</windowed>". You might also want to adjust the resolution from "0,0" which is desktop res to something less than your desktop so it doesn't get clipped.

Let me know if you have any questions.

Level 7 Human gamer
Alignment: Lawful
Posted on January 10, 2014 at 8:45 pm

Unrelated note: the 650 Ti is a piece of crap. That card was what finally convinced me to switch to AMD cards =|

Level 5 Human gamer
Alignment: True neutral
Posted on January 10, 2014 at 9:05 pm

Hurray!
That has fixed it for me! Thanks for your help, I can now get down to testing.

Edit: Just noticed that you cannot enable Anti-Aliasing, can AMD cards enable it?

Hayden

Level 8 Human gamer
Alignment: Chaotic evil
Posted on January 10, 2014 at 10:32 pm

Just confirmed, that windowed thing is working for me as well, with my nvidia card. Better than nothing!

Level 7 Human Master & Commander, HMS Spitfire
Alignment: Lawful
Location: N. Atlantic, 1793
Posted on January 11, 2014 at 1:45 am

Changing settings.xml worked for me, too. Thanks!

Level 17 Extraplanar gamer
Alignment: True neutral
Posted on January 11, 2014 at 2:06 am

Update: I've found a solution that fixes the crash in fullscreen, but I'm still not clear why it was crashing in the first place and I don't know if the fix has any side effects. We're going to do a little more testing, but we should have an update with a proper fix early next week.

Level 7 Human gamer
Alignment: True neutral
Posted on February 18, 2014 at 10:59 pm

This issue is also showing up in Hegemony Gold - Wars of Ancient Greece... please fix this as well when updating Rome

Level 5 Human gamer
Alignment: True neutral
Posted on February 27, 2014 at 1:18 pm

This issue is also showing up in Hegemony Gold - Wars of Ancient Greece... please fix this as well when updating Rome

Same here, just purchased Gold while i wait on Caesar :) but same error, would be nice to play Greece Full Screen also.

Level 6 Human gamer
Alignment: True neutral
Posted on November 11, 2014 at 2:30 am

HI, any fix for this error?