Skip navigation

Lag issues in Gold (Steam Version)

Forum NavigationHome > Forum Index > Hegemony > Lag issues in Gold (Steam Version)
Level 8 Human gamer
Alignment: True neutral
Posted on September 20, 2012 at 1:25 am

After playing the original PoM game i finally got around to playing the campaign in Gold. I've taken out the Paeonian, the Illyrians, pushed 4 cities east of Pella, South as far as Olooson (not counting the few Athenian cities east of Aegae), and south west through epirus (i stopped after i completed the objective there)

One issue i have started to see is a lag issue when i'm trying to manage a fight. Say i have about 5 units on screen, 3 are mine, 2 are the enemy, then there is usually a lag every 30s or so...particularly when I i tell one of my units to specifically attack another, or if any of the units rout. I never had any issue on PoM, and i have since dropped the detail level to low and while it resolved the issues when I controlled less of the map, now that I control more the issue has arisen again.

Anyone have any idea how to resolve it?

Level 7 Human Let's Player
Alignment: Chaotic evil
Location: New Mexico
Posted on September 20, 2012 at 2:50 pm

Hard to say, are you running anything besides the game that is taking up a lot of memory? I have not had any issue with lag but then again if I did I would of blamed it on fraps or something other then the game. Also how old is your computer, even though I doubt this game is high graphic demanding it might just be the lack of physical memory causing everything to slow down. Hope this helps if not let me know and I will try again.

Level 7 Human gamer
Alignment: Lawful good
Location: German-speaking part of Europe
Posted on September 20, 2012 at 3:58 pm

How do you think the map can be zoomed in and out freely without having that data loaded into your memory everytime you play? And the further you progress, the more of the map has to be loaded in all the time...

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on September 20, 2012 at 5:31 pm

Some information that would help us diagnose the problem:

* Your system specs. (If you open dxdiag as described here, the information on the System and Display tabs is what's important.)
* How long the lag spikes last. (e.g. half a second? 1 second? 5 seconds?)
* Do you experience more or less lag spikes on different parts of the map?
* You said you experience the lag spikes every 30 seconds or so. How regular is that? Is it always close to 30 seconds, or can it vary wildly (e.g. from 5 seconds to 2 minutes)?
* Compared to your PoM playthrough, have you discovered more of the map, or less?

Get back to us and we'll see what we can suggest. In the meantime, here's a couple routine system tune-ups that could help:
* Make sure you have the latest video drivers installed.
* Defrag your drive. In your 'My Computer' window, where you can find your hard drives, right-click on the C: drive and choose 'Properties'. The 'Tools' tab has a button called 'Defragment' or 'Optimize'.

Level 8 Human gamer
Alignment: True neutral
Posted on September 21, 2012 at 12:46 am

Hard to say, are you running anything besides the game that is taking up a lot of memory? I have not had any issue with lag but then again if I did I would of blamed it on fraps or something other then the game. Also how old is your computer, even though I doubt this game is high graphic demanding it might just be the lack of physical memory causing everything to slow down. Hope this helps if not let me know and I will try again.

This is a newer setup then when i was running PoM. also not running anything demanding in the background. I can get the specific specs once i'm at home.

How do you think the map can be zoomed in and out freely without having that data loaded into your memory everytime you play? And the further you progress, the more of the map has to be loaded in all the time...
I understand that, but i'm seeing the lag occasionally when i'm zoomed in managing a fight. and seeing the lag when I change attack/movement of a unit or if any of the units on screen rout.

Some information that would help us diagnose the problem:

* Your system specs. (If you open dxdiag as described here, the information on the System and Display tabs is what's important.)
* How long the lag spikes last. (e.g. half a second? 1 second? 5 seconds?)
* Do you experience more or less lag spikes on different parts of the map?
* You said you experience the lag spikes every 30 seconds or so. How regular is that? Is it always close to 30 seconds, or can it vary wildly (e.g. from 5 seconds to 2 minutes)?
* Compared to your PoM playthrough, have you discovered more of the map, or less?

Get back to us and we'll see what we can suggest. In the meantime, here's a couple routine system tune-ups that could help:
* Make sure you have the latest video drivers installed.
* Defrag your drive. In your 'My Computer' window, where you can find your hard drives, right-click on the C: drive and choose 'Properties'. The 'Tools' tab has a button called 'Defragment' or 'Optimize'.



I'll get the specs from you later tonight once i'm at home. I also have my computer on a defrag schedule so that is not an issue, same as drivers as I have the latest drivers installed.

The lags spike lasts about 3-5s, and I usually hit pause when it happens so that once the lag stops it is paused and I can take stock of what is happening.

In regards to the map location, it has been anywhere on the map where there are more than 5 units on screen at a time. And it only happens when this scenario exists and when the status (that might be the way of explaining) of a unit changes (i.e. move to a different position, attack a particular unit, unit routed). if the fight continues without my intervention or any unit routing, then there is no lag seen)

Regarding PoM, i completed the whole map without any lag issues. currently still early game in Gold.