Skip navigation

Stuck on beginning loading screen

Forum NavigationHome > Forum Index > Hegemony > Stuck on beginning loading screen
Level 6 Human gamer
Alignment: True neutral
Posted on July 29, 2012 at 5:47 am

Hi, so I bought Hegemony Gold from Steam last week, and I just installed it. However, the game seems to get stuck on the loading screen for me. The little arrow on the Argead star is moving, and I'm getting different hints every once in a while, but it's been eight minutes. The first time I also waited about eight minutes. Do the loading screens typically take this long? Should I just be patient?

Thanks.

Level 21 Extraplanar gamer
Alignment: True neutral
Location: Toronto
Posted on July 29, 2012 at 1:47 pm

Hegemony unpacks the audio files when it runs for the first time. This can take some time, but not as long as you describe.

Right click on the Hegemony link in your Steam Library, choose "Properties", then "Local Files" tab and click on "Verify Integrity of Game Cache"... Try a few things there, including deleting the local content and reinstalling it, if need be...

Otherwise, Rob or Rick will need to get involved.

Level 6 Human gamer
Alignment: True neutral
Posted on July 29, 2012 at 4:13 pm

Yep, I forgot to say, I did try verifying the integrity of the game cache. Turned out fine. Have not tried re-installing it though.

Good to know that it takes some time the first time. I'll just let it run when I eat my dinner or something. Will get back to you either way.

Level 16 Extraplanar gamer
Alignment: True neutral
Posted on July 30, 2012 at 6:03 pm

The screen should say something like 'Decompressing Sounds ...' when it's unpacking the sound files for the first time so I'm not sure if that's your problem. If you're still having issues I'd suggest uninstalling it from Steam and re-downloading it or using the installer from our website (http://www.longbowgames.com/downloads/Hegemony%20Gold%20Installer.exe) with the CD-Key from your Steam library.

Let us know if you need more help and feel free to e-mail us directly if you wish (rob@longbowgames.com or rick@longbowgames.com)

Level 6 Human gamer
Alignment: True neutral
Posted on March 1, 2013 at 2:01 am

Hey there, quick update on this. I just got a new computer and decided to give Hegemony another shot, it ran pretty much flawlessly. It was probably my computer's problem.

Having a blast so far. I don't think I've played a game that models classical empire-building half so well, I feel like I'm playing out a chapter from Thucydides. :]