Skip navigation

Support for other keyboard layouts

Forum NavigationHome > Forum Index > Hegemony > Support for other keyboard layouts
Level 8 Human gamer
Alignment: True neutral
Posted on December 9, 2010 at 11:14 am

I've just found and purchased this great game.

Though I have no issue running it in English, my keyboard has a French layount (AZERTY instead of QWERTY) and so panning and all that stuff is a bit of a pain.

It would be great to have a standard "remap your keys" in the options.

Thank you and keep up the good work.

JP
PS: I looked for a way to search the forums so I wouldn't post about something that's been said, but couldn't find it.

Level 21 Extraplanar gamer
Alignment: True neutral
Location: Toronto
Posted on December 9, 2010 at 9:06 pm

From the ingame menu open "Options". From there open "Gameplay" and from there, "Controls" to change the keyboard mapping.

Level 9 Human gamer
Alignment: True neutral
Location: Rennes, France
Posted on December 19, 2010 at 6:13 pm

From the ingame menu open "Options". From there open "Gameplay" and from there, "Controls" to change the keyboard mapping.
Well, in the "controls" sub-menu you describe, you can't change the mapping ...
I have an AZERTY keyboard too, and it would be great to use the zsqd mapping (not wsdq).
:(

Level 8 Human Cyborg
Alignment: Good
Posted on December 19, 2010 at 7:27 pm

From the ingame menu open "Options". From there open "Gameplay" and from there, "Controls" to change the keyboard mapping.
Well, in the "controls" sub-menu you describe, you can't change the mapping ...
I have an AZERTY keyboard too, and it would be great to use the zsqd mapping (not wsdq).
:(


You can manually edit the Controls.xml file (use Notepad or similar) to change all the key mappings.

Search for VK_W change to VK_Z etc

Level 9 Human gamer
Alignment: True neutral
Location: Rennes, France
Posted on December 20, 2010 at 5:51 pm

From the ingame menu open "Options". From there open "Gameplay" and from there, "Controls" to change the keyboard mapping.
Well, in the "controls" sub-menu you describe, you can't change the mapping ...
I have an AZERTY keyboard too, and it would be great to use the zsqd mapping (not wsdq).
:(


You can manually edit the Controls.xml file (use Notepad or similar) to change all the key mappings.

Search for VK_W change to VK_Z etc


Oh, thanks for the tip. It's ok, now ;)