Skip navigation

Incredibily low fps in Demo (Hegemony: Philip of Macedon)

Forum NavigationHome > Forum Index > Longbow Support > Incredibily low fps in Demo (Hegemony: Philip of Macedon)
Level 9 Human gamer
Alignment: True neutral
Posted on November 7, 2010 at 8:25 pm

A friend told me about this game, so my curiosity made me download the demo to try out the game; however when going into the game I receive a very large fps drop when panning or scrolling. I tried lowering the settings yet was unable to get a significant difference, this only happens on closer map (Not the overview map with simplified figures for units).

Here is some system specifications, I will post a dxdiag if it is needed.
Processor:
AMD Phenom(tm) II X4 955 Processor (4 CPUs), ~3.2GHz
Memory:
4096MB RAM
Video Card:
2 ATI Radeon HD 5700 Series
Operating System:
Windows 7 Professional 64-bit


If there is a solution to this issue, I would greatly appreciate it as if it became fixed I would probably end up buying the game. :)

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on November 9, 2010 at 3:52 am

Hey Zstar, your machine should definitely be able to run Hegemony. The first thing I would do is install and run CPU-Z to make sure your CPU is running at the advertised speed. You should be able to see the core speed in the bottom-left box, and if it's not around 3200 MHz when your computer is under stress (try running Hegemony in a window next to CPU-Z) then you probably need to update your BIOS or play with its settings.

Aside from that, it can also be useful to make sure your CPU and GPU aren't overheating. You should be able to check your GPU's temperature in the Catalyst Control Centre, and SpeedFan is a decent app for checking your CPU's temperature.

Level 9 Human gamer
Alignment: True neutral
Posted on November 9, 2010 at 3:44 pm

Hey Zstar, your machine should definitely be able to run Hegemony. The first thing I would do is install and run CPU-Z to make sure your CPU is running at the advertised speed. You should be able to see the core speed in the bottom-left box, and if it's not around 3200 MHz when your computer is under stress (try running Hegemony in a window next to CPU-Z) then you probably need to update your BIOS or play with its settings.

Aside from that, it can also be useful to make sure your CPU and GPU aren't overheating. You should be able to check your GPU's temperature in the Catalyst Control Centre, and SpeedFan is a decent app for checking your CPU's temperature.

Rick, I just want to say right now; I feel like a complete and utter moron.

Why?

Installed CPU-Z, ran Hegemony out of fullscreen.

No hitches, but I had yet done fullscreen; now it is flawless, barely any stutter.

So no more problems, and I can finally enjoy the game without the incredibly low fps; and I have no problem running out of fullscreen as I do that with most of games anyways.

So yeah, I plan on buying it soon due to this issue being fixed. :)

Thanks for the quick response Rick, I will post in this forum if I have any issues as well as my excitement for gold. ;)

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on November 10, 2010 at 1:28 am

Glad to hear you got it sorted out.

In case you want to have a go at getting it to run smoothly in fullscreen mode, the two most common reasons I've seen for a game running slowly in fullscreen mode are either:

a) The graphics card has a low fill-rate; this just means you need to run the game at a lower resolution, or
b) The graphics card or monitor doesn't like it when the game isn't running at the monitor's native screen resolution, in which case you need to make sure you're running at the native resolution (this is usually — but not always — the desktop resolution). This problem seems to be more common on laptops.