Skip navigation

TM resolution registry settings or NVIDIA settings...(Windows XP - NVIDIA GeForce 8700M GT)

Forum NavigationHome > Forum Index > Longbow Support > TM resolution registry settings or NVIDIA settings...(Windows XP - NVIDIA GeForce 8700M GT)
Level 17 Human gamer
Alignment: True neutral
Posted on March 3, 2010 at 10:53 pm

Greetings,
I've been off TM since I am getting delay in the game...
Once, Rick I think; posted the location in the registry to manually change the resolution. I can't seem to find it.
I changed config.cfg to GLWidth = 1920, GLHeight = 1200 (my laptop's resolution) but that didn't do much.
I'm on a Dell XPS M1730 (2.2Ghz, 2GB RAM), NVIDIA GeForce 8700M GT driver version: 9.09.0814).
I'm getting delay when i play, it plays ok but then it skips a second or two once in a while. I noticed changing some of the NVDIA control panels custom configurations for the application (TM.exe) helps a little but not sure what to change...lol: (set everything to off.. but still some delay)
NVIDIA Control Panel settings (options)
1. Anisotropic filtering: Use global setting (Application-controlled)/Application-controlled/Off/2x/4x/8x/16x
2. Antialiasing - Gamma correction: Use global setting(on)/Off/On
3. Antialiasing - Mode: Use global setting (Application-controlled)/ Application - controlled/Off/Enhance application/Overide any application settings
(the list goes on... feature names)
4. Antialiasing - Transparency
5. Maximum pre-rendered frames
6. Multi-display/mixed-GPU acceleration
7. Texture filtering - Anisotropic sample optimization
8. Threaded optmization
9 Triple buffering
10. Vertical sync (this one actually changes the behavior a lot!)

Do you know what's going on? (all other applications are ok, it's just TM.... I tried reisntalling all... I am using the latest supported driver for this video card from NVIDIA... i tried using older driver but still (delay).... the only other option was the original driver that came the laptop with but TM started to mess up after playing a while... and that's an outdated nvidia driver :| (help please) what's the correct setup for this card!?

Level 13 Human Cyb0rg tank pil0t:|@- ҉҈҉҈҉-§¹Ç--҉҈҉-
Alignment: Chaotic good
Location: Standby In Winters's North
Posted on March 6, 2010 at 12:24 am

Greetings,
I've been off TM since I am getting delay in the game...
Once, Rick I think; posted the location in the registry to manually change the resolution. I can't seem to find it.
I changed config.cfg to GLWidth = 1920, GLHeight = 1200 (my laptop's resolution) but that didn't do much.
I'm on a Dell XPS M1730 (2.2Ghz, 2GB RAM), NVIDIA GeForce 8700M GT driver version: 9.09.0814).
I'm getting delay when i play, it plays ok but then it skips a second or two once in a while. I noticed changing some of the NVDIA control panels custom configurations for the application (TM.exe) helps a little but not sure what to change...lol: (set everything to off.. but still some delay)
NVIDIA Control Panel settings (options)
1. Anisotropic filtering: Use global setting (Application-controlled)/Application-controlled/Off/2x/4x/8x/16x
2. Antialiasing - Gamma correction: Use global setting(on)/Off/On
3. Antialiasing - Mode: Use global setting (Application-controlled)/ Application - controlled/Off/Enhance application/Overide any application settings
(the list goes on... feature names)
4. Antialiasing - Transparency
5. Maximum pre-rendered frames
6. Multi-display/mixed-GPU acceleration
7. Texture filtering - Anisotropic sample optimization
8. Threaded optmization
9 Triple buffering
10. Vertical sync (this one actually changes the behavior a lot!)

Do you know what's going on? (all other applications are ok, it's just TM.... I tried reisntalling all... I am using the latest supported driver for this video card from NVIDIA... i tried using older driver but still (delay).... the only other option was the original driver that came the laptop with but TM started to mess up after playing a while... and that's an outdated nvidia driver :| (help please) what's the correct setup for this card!?


i've had a similar but worse error in the past with tread marks with my old video card which was an ati x700 pro series gaming video card i found that it wasn't the drivers or card the problem was tread marks not being very compatible with it

tread marks 1.60 and older have a bit of trouble with newer graphics cards or hardware however you can tweak it to run better so for starters what version are you using 1.60? also if you can't find the reg key you can use a tool that killer for forcing tread marks to render certain resolutions it doesn't like if that will fix your problem

it sounds like you've done most of everything to fix it rick can probably give us more info i have a nvidia 9600 gso series graphics card and it runs much better than my older video card i use the newer 1.62 version which for me runs more stable and is better compatible with newer devices such as its purpose to work with vista and comparing to tread marks 1.60 being 5 or more years old.

tell me anything else you may know i might be able to help.

Level 17 Human gamer
Alignment: True neutral
Posted on March 7, 2010 at 8:06 pm

after all troubleshooting and wasted time, i noticed the net rate in the game was set too low (1K/sec) once i increased that to 5K (10K is the max but did not noticed any difference) it actually made it work almost ok (a little lag still).
The other thing i found out is that NVIDIA scaling and other crappy settings that just customizes your video to the point of puking it is not worth it! I may have to use a profile for this game so they won't use any 'enhancements' to just show the picture... so above all net rate was it (game > miscellaneous) i changed other settings that helped but this was the one causing the problem...

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on March 11, 2010 at 5:41 am

First off, the registry location for the resolution is:

HKEY_CURRENT_USER\Software\Longbow Digital Arts\Tread Marks 1.5

The values are called GLBWIDTH and GLBHEIGHT. Don't forget to click 'decimal' when changing these ;)

It looks like you've already got the lag thing sorted out. In case anybody else should stumble upon this, here's a couple other common causes:

* Some video cards or monitors also hate certain resolutions, so changing your resolution might help (particularly changing it to the native resolution of your monitor).

* Another unfortunate cause of visual lag is if you've got your computer hooked up to a TV. Some TVs have a setting that claims to 'reduce motion blur', or something to that effect. Those settings usually aren't worth it, because they just cause lag. However, if this is the case for your TV, then you'd probably notice some lag when simply moving your cursor on your desktop.

Level 13 Human Cyb0rg tank pil0t:|@- ҉҈҉҈҉-§¹Ç--҉҈҉-
Alignment: Chaotic good
Location: Standby In Winters's North
Posted on March 12, 2010 at 8:11 pm

First off, the registry location for the resolution is:

HKEY_CURRENT_USER\Software\Longbow Digital Arts\Tread Marks 1.5

The values are called GLBWIDTH and GLBHEIGHT. Don't forget to click 'decimal' when changing these ;)

It looks like you've already got the lag thing sorted out. In case anybody else should stumble upon this, here's a couple other common causes:

* Some video cards or monitors also hate certain resolutions, so changing your resolution might help (particularly changing it to the native resolution of your monitor).

* Another unfortunate cause of visual lag is if you've got your computer hooked up to a TV. Some TVs have a setting that claims to 'reduce motion blur', or something to that effect. Those settings usually aren't worth it, because they just cause lag. However, if this is the case for your TV, then you'd probably notice some lag when simply moving your cursor on your desktop.


also if you want to speed the game up online or if the problems is dealing with the Internet you can change the net rate higher then 10k i have mine set to 1000k or 1 mbps i would recommend that rate minimum unless you have something as slow as a modem

if you look in the HKEY_CURRENT_USER\Software\Longbow Digital Arts\Tread Marks 1.5 you'll find

Net rate or similar reg name

it shouldn't be hard to find it when you find it change it as decimal and just set it to 1000 or set it depending on how much bandwidth your ISP offers


rick in a future update could you allow people to set a higher net rate i have high speed Internet and tread marks would run way better online and would be less annoying to set the net rate higher without having to go into the registry and force TM to utilize something higher that it won't let me set.

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on March 15, 2010 at 8:26 pm

The settings are definitely showing their age. The last time I updated TM I changed the default settings, and I should probably have increased the net rate as well, since most people don't play on modems anymore.

Level 13 Human Cyb0rg tank pil0t:|@- ҉҈҉҈҉-§¹Ç--҉҈҉-
Alignment: Chaotic good
Location: Standby In Winters's North
Posted on March 17, 2010 at 9:08 pm

The settings are definitely showing their age. The last time I updated TM I changed the default settings, and I should probably have increased the net rate as well, since most people don't play on modems anymore.

well if you ever change the net rate keep the support for the modem speed because i have a few friends that still use dial up surprisingly.

besides the net rate you should allow more textures and other general graphics to be set higher too if you ever get to updating TM that is

i have a top notch high-end gaming video card and i also have too tweak the texture res and other settings to force changes i alter the config file if TM is being pushy i go into the registry and change the value's myself

believe me rick 4000 texture res is so beautiful and amazing that TM could look much better than it ever has of course your video card has to support it which most people's video cards can support nowadays up to 1000 to 1500 texture res if you have a good video card.

Level 14 Human Shadow
Alignment: Chaotic good
Location: Earth Orbit, Preparing to Attack
Posted on April 20, 2010 at 6:30 pm

A2597 made a high res texture mod. I've been using it for years - excellent!

I'll see if I can dig up the zip file.

Level 13 Human Cyb0rg tank pil0t:|@- ҉҈҉҈҉-§¹Ç--҉҈҉-
Alignment: Chaotic good
Location: Standby In Winters's North
Posted on April 27, 2010 at 3:45 pm

A2597 made a high res texture mod. I've been using it for years - excellent!

I'll see if I can dig up the zip file.


i've used it before, its good however it is really only a simple mod

problem is it only supports textures it also has major flaw it only loads stock TM content zero mods and doesn't do anything better that i could easily implement

its not made by lda and it should be an official upgrade to TM for the new users who would play it

forcing texture res higher than 512 looks better

but there isn't as big of a major difference than adding HQ textures

example 4000 tex res = 4000 pixel textures

i also said other settings

which meant other graphics settings like high - low meshs ,quality vice versa

which means two more things

HQ Maps AND Tanks

if you updated the tank meshes\maps for better quality i can tell you with every change i stated TM would look as good as games 6 years ahead

if i owned tm i would do a total update overhaul to it

voip chat, story line, better physics, graphics,even more

if i did that maybe most people would come back and replay it

TM'S a great game but could be way better!