Skip navigation

Creating a LAN game

Forum NavigationHome > Forum Index > Longbow Support > Creating a LAN game
Level 11 Human gamer
Alignment: True neutral
Posted on November 30, 2008 at 2:07 pm

I've bought the TreadMarks game and tried to make a Lan game. I wasn't able to do a dedicated server and just click on Allow Joins when creating a game. It is working, but unfortunately it is extremely laggy even with the net link set to 10k/sec. Is there any solution?

Level 14 Human Shadow
Alignment: Chaotic good
Location: Earth Orbit, Preparing to Attack
Posted on November 30, 2008 at 2:49 pm

1. What sort of network connection are you using? Wireless? Wired? Wireless connections can be quite laggy, depending on how good your signal quality is.

2. Why did making a dedicated server not function?

3. Have you added a lot of mods? Some weapons, such as mines or multi-shot/splitting weapons, can cause significant lag.

Last, for a dedicated server, increase DedicatedFPS in your config file to 10. I'd not recommend it above 10, unless you've got a nice fast LAN set up. 10 is good, generally. Basically, this is the number of frames updated to clients per second, syncing them with the server. Higher is less jerky, less laggy play, providing you have the bandwidth to support it. If you have it higher than your bandwidth can support, though, the lag will go way up.

Level 11 Human gamer
Alignment: True neutral
Posted on November 30, 2008 at 3:00 pm

1. I have a mixed network, but my 2 computers are wired. So I think I should not have problem with bit rate.

2. I've bought the game this morning, but I had the demo before. When I open the game, It still shows 'Demo'' on top, but I have all features of the Full game. Dunno if its why I'm not able to start the dedicated server.

3. I don't have any mods for the moment.

Well, I don't have that much knowledge on how setting up the dedicated server, how do you set the DedicatedFPS in the config file, because the notepad is blank.