Skip navigation

Particle Fire 2 Has Encountered an Error?

Forum NavigationHome > Forum Index > Longbow Support > Particle Fire 2 Has Encountered an Error?
Level 12 Human gamer
Alignment: True neutral
Posted on October 29, 2007 at 9:14 pm

I've been using Particle Fire as my default screen saver on multiple machines for some time now, but recently, I've encountered an issue with the installation on my laptop. A week or so ago, I inexplicably began getting that wondererful ...has encountered an error and has to close dialog box from Windows XP every time the screen saver tried to come on, offering to notify Microsoft of the problem. Well, I had a bunch of programs running at the time, so after a bit, I shut everything down and rebooted, figuring that it was a system resources issue.

For a couple of days, all was well once more, but this evening it started doing it again. So I closed everything down and restarted again. Except it didn't help this time. So I uninstalled Particle Fire, downloaded the newest version, and tried to run it. Still no joy. I get the same error when trying to preview the screen saver as I would if I let it load normally after the 15 minute delay. However, the mini-preview on the screensaver screen displays fine.

I have tried uninstalling, rebooting, and reinstalling, uninstalling and reinstalling without rebooting, and nothing seems to work. On the theory that something in the registry that isn't getting deleted with an uninstall was corrupted, I even hunted through Regedit and deleted all references I could find for particle fire but that didn't help either (I must have missed something, though, because on the next install, it still knew my registration key). Help?

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on October 31, 2007 at 4:30 pm

Well, try uninstalling the game, and after you've uninstalled, make sure that the Program Files/LDA Games/Particle Fire folder doesn't exist. (If it does, delete it.)

Now, run the regedit program (Go to Start->Run and type RegEdit , or press Windows-Key+R and type RegEdit ) and navigate to HKEY_CURRENT_USER\Software\Longbow Digital Arts and make sure there's no Particle Fire folder. If there is, delete it.

Now, try re-installing. Because we haven't updated Particle Fire for Vista yet, if you're using Windows Vista, it's important that you right-click on the installer and choose Run as Administrator to run the installer instead of just double-clicking on it like normal.

If it still doesn't work, let me know.

Also, I just want to make sure: you mean Particle Fire 1 and not 2, right?

Level 12 Human gamer
Alignment: True neutral
Posted on October 31, 2007 at 5:17 pm

Nope, I mean Particle Fire 2. And I'm still on XP, so the Vista bit isn't relevant.

I'll try your advice with regards to the registry when I get home this evening, but I can say for sure that the Particle Fire folder in Program Files was not still there after uninstall.

Would it matter that when I originally installed it, I changed the install path to Program Files/Particle Fire instead of Program Files/LDA Games/Particle Fire ? All but one of the times I attempted to remove/reinstall it I followed the same path--once I forgot to make the adjustment. I tend to do that with things like this, so that I can find them when I go looking for them--I might not necessarily remember what company made a given piece of software, but I generally remember the name of the software I'm after.

Level 12 Human gamer
Alignment: True neutral
Posted on October 31, 2007 at 10:31 pm

Yay! All better now. I should have been paying attention to which section of the registry I was searching--I was only removing entries in the HKEY_USERS section, and didn't touch any of the ones that were in HKEY_CURRENT_USER, and so the ones that needed to be cleared out were never removed. This time, on reinstall, I put my key back in, and it works fine. Thanks!

Level 14 Extraplanar Programmer
Alignment: Chaotic good
Location: Toronto
Posted on November 2, 2007 at 3:31 am

Glad to hear everything is working for you now. Cheers!