|
Author Topic:   HELP!!!...the clan flag are not showing correctly
666
Member
posted September 26, 2003 03:13 AM            
Here is my problem. The master flag pack and clan flag pack got installed on the stock side not the Addons folder.

What flag options that shows up on the Tank option screen when you are in the clan server are all 6 colors and the clan flags to choose. That makes 12 flags, black, blue, gold, white, green, red, BWL, DNX, DOG, GA, LWA, and TC. The server is only set for 6 teams. So only the 1st three colors and 1st 3 clan can have flags that show.

I have checked it out in single player what the flags should be showing. It should only list the colors under tank options flag selection.

I replace the teamlogo folder and deleted the iwo flag files from the object file on the stock side. It did clear up the fact that the gold flag was displaying the GA flag, not the DOG flag. But still all 12 flags still come up, thus only the black, blue, gold, BWL, DNX, and DOG flags to be selected.

Does any one know what files make the clan names show up under the tank options flag selections? I think if I delete these files then it could be savaged.

Otherwise I am going to just start replacing folders till it is resolved.

Mind you, I guess I could try 12 teams...then all 12 flags would show...LOL

[This message has been edited by 666 (edited September 26, 2003).]

IP:

Rex R
Member
posted September 26, 2003 03:51 AM            
there is one set of ents in ents\flags and another in \insignia\ 'teamxxxx.ent' (also banner) believe its the 'teamxxx' ents that are causing you headaches. quick 'n dirty method would be to delete and reinstall both folders. think the only mod flag I put in the 'stock' folders is the stars and stripes released by lda

IP:

BamZipPow
Member
posted September 26, 2003 03:52 AM            
Is this on one of the servers? Or just on yer comp?

IP:

Rex R
Member
posted September 26, 2003 04:02 AM            
I gather this is on the clan battle server

IP:

BamZipPow
Member
posted September 26, 2003 04:20 AM            
Yah...I just visited it. It's on there. I can rip out the affected folder and entities...

IP:

BamZipPow
Member
posted September 26, 2003 05:00 AM            
There...all fixed. The flags are as they should be.

You do know that you have to restart the server anytime you make changes to it, right?

IP:

BamZipPow
Member
posted September 26, 2003 06:47 AM            
Just out of curiousity...what would LogScan do if it would've been left that way?

IP:

KiLlEr
Member
posted September 26, 2003 09:02 AM            
SInce LogSCan reads the log file, it will pick up whatever the team name is when TM writes:

"player xxx joined team yyy"
"player xxx picked up team yyy flag"
"the yyy flag has been dropped"

messages into the log.

The only hitch is that for CTF, I only keep track of flag captures for the stock 6 colors, since I neeede to have a seperate column for each team on the database table. THe column names are the 6 colors in the stock TM configuration.

DM games are unaffected. It will simply store the name of the team on the player record regardless of what it is.

[This message has been edited by KiLlEr (edited September 26, 2003).]

IP:

666
Member
posted September 26, 2003 09:14 AM            
thank you all for resolving this...especially this late at nite.

IP:

BamZipPow
Member
posted September 26, 2003 06:21 PM            
Just so you know, if there are other TeamXXX.ent files in the entities/insignia folder besides the standard 6, you will get "more" teams.

I'm experiementing and there doesn't really seem to be a limit on the number of teams so far. It will probably top out at 99 or something. That would be a lot of teams!

The only thing you would have to be careful with is when you have CTF. Without enough Team flag points to support the number of teams, the "flagless" teams will have no where to take their flags to...

IP: