|
Author Topic:   shadowsummoner won't pass ENTegrity
coaxs
Member
posted June 03, 2002 04:27 AM            
Vlad, could you please give a link to a clean copy. please-please

------------------
Tread Marks Ladders

IP:

Vlad
Member
posted June 03, 2002 09:04 AM            
You know, I do put my email addy in the readme files .

Make sure you've got a fully up to date version of ENTegrity. Older versions were always made sure that file and type names matched, which isn't necessary. So, since the Shadow Summoner references some of the Shadow Keeper files, which don't have matching file and type names, it causes errors.

Either way, clean version here:
http://members.bellatlantic.net/~vze26xhe/Treadmarks/ShadowSummonerOnline_v150.zip

IP:

=DNX= Matrix
Member
posted June 03, 2002 12:19 PM            
i didnt even know a newsew version of entegrity was out...... time to update i think.

IP:

coaxs
Member
posted June 03, 2002 01:49 PM            
I downloaded ENTegrity yesterday so I assume I have the full version

IP:

BamZipPow
Member
posted June 03, 2002 01:56 PM            
I believe that the latest version is 1.13...

IP:

Vlad
Member
posted June 03, 2002 02:25 PM            
quote:
I downloaded ENTegrity yesterday so I assume I have the full version

In that case, what errors were you getting? Are you still getting them with the zip I linked to?

IP:

coaxs
Member
posted June 04, 2002 06:07 PM            
The zip you provided also has DarkNovaCruise, ShadowSummoner, Supershadow summoner, are they stand alone weapons themselves? Or are they just parts of the mod?

Kevlar's Weapon Master pack did not have DarkNova cruise or Super shadow summoner in it. ENTegrety passed DarkNovaCruise just fine.

The shadow summoner ent you provided in the zip came up with 5 errors. listed here

quote:
ERROR. Line number 36 (namely, 'EntityChain1 = Explo/ShadowMine2Explo2') of file "C:\Tread Marks Entegrity Tests\Addons\Entities\ExploSphere\ShadowMine2Explo.Ent" contains ERROR-0402 -- Entity file referenced does not have a valid class/type pair. I searched the 674 Class/Type pairs (every .ent file in your Main and Addons folders) for "Explo/ShadowMine2Explo2", but was unsuccessful. Another error or warning message will likely follow this one that may help you debug this situation.

ERROR. Line number 3 (namely, 'Type = ShadowMine1Explo') of file "C:\Tread Marks Entegrity Tests\Addons\Entities\Explo\ShadowMine2Explo2.Ent" contains ERROR-0600 -- Type mis-match. The 'Type = ' parameter should equal the file name (less the .ent). Your file name is C:\Tread Marks Entegrity Tests\Addons\Entities\Explo\ShadowMine2Explo2.Ent, but your 'type = ' parameter is shadowmine1explo.

ERROR. Line number 25 (namely, 'expandstart =3 ') of file "C:\Tread Marks Entegrity Tests\Addons\Entities\Explo\ShadowMine2Smoke2.Ent" contains ERROR-0525 -- Does not have an equal sign (=) separated by spaces. Tread Marks parameter format is: 'Parameter = Argument'.

ERROR. Line number 2 (namely, 'type = wonk') of file "C:\TREAD MARKS 1.6 Stock\Entities\Spewer\WonkSpew.Ent" contains ERROR-0600 -- Type mis-match. The 'Type = ' parameter should equal the file name (less the .ent). Your file name is C:\TREAD MARKS 1.6 Stock\Entities\Spewer\WonkSpew.Ent, but your 'type = ' parameter is wonk.

ERROR. Line number 45 (namely, 'PropogateSpew = 0') of file "C:\Tread Marks Entegrity Tests\Addons\Entities\Spewer\ShadowCrashSmoke.Ent" contains ERROR-0205 -- Parameter PropogateSpew not found for class = spewer. According to the CatchallRules.txt file, this parameter is not defined to Tread Marks at all. Check the spelling for PropogateSpew.


The SuperShadowSummoner ent in the weapons folder had these following 6 errors.

quote:
ERROR. Line number 36 (namely, 'EntityChain1 = Explo/ShadowMine2Explo2') of file "C:\Tread Marks Entegrity Tests\Addons\Entities\ExploSphere\ShadowMine2Explo.Ent" contains ERROR-0402 -- Entity file referenced does not have a valid class/type pair. I searched the 674 Class/Type pairs (every .ent file in your Main and Addons folders) for "Explo/ShadowMine2Explo2", but was unsuccessful. Another error or warning message will likely follow this one that may help you debug this situation.

ERROR. Line number 3 (namely, 'Type = ShadowMine1Explo') of file "C:\Tread Marks Entegrity Tests\Addons\Entities\Explo\ShadowMine2Explo2.Ent" contains ERROR-0600 -- Type mis-match. The 'Type = ' parameter should equal the file name (less the .ent). Your file name is C:\Tread Marks Entegrity Tests\Addons\Entities\Explo\ShadowMine2Explo2.Ent, but your 'type = ' parameter is shadowmine1explo.

ERROR. Line number 25 (namely, 'expandstart =3 ') of file "C:\Tread Marks Entegrity Tests\Addons\Entities\Explo\ShadowMine2Smoke2.Ent" contains ERROR-0525 -- Does not have an equal sign (=) separated by spaces. Tread Marks parameter format is: 'Parameter = Argument'.

ERROR. Line number 2 (namely, 'type = wonk') of file "C:\TREAD MARKS 1.6 Stock\Entities\Spewer\WonkSpew.Ent" contains ERROR-0600 -- Type mis-match. The 'Type = ' parameter should equal the file name (less the .ent). Your file name is C:\TREAD MARKS 1.6 Stock\Entities\Spewer\WonkSpew.Ent, but your 'type = ' parameter is wonk.

ERROR. Line number 2 (namely, 'type = ShadowShipDN') of file "C:\Tread Marks Entegrity Tests\Addons\Entities\Spewer\ShadowDNShot.Ent" contains ERROR-0600 -- Type mis-match. The 'Type = ' parameter should equal the file name (less the .ent). Your file name is C:\Tread Marks Entegrity Tests\Addons\Entities\Spewer\ShadowDNShot.Ent, but your 'type = ' parameter is shadowshipdn.

ERROR. Line number 45 (namely, 'PropogateSpew = 0') of file "C:\Tread Marks Entegrity Tests\Addons\Entities\Spewer\ShadowCrashSmoke.Ent" contains ERROR-0205 -- Parameter PropogateSpew not found for class = spewer. According to the CatchallRules.txt file, this parameter is not defined to Tread Marks at all. Check the spelling for PropogateSpew.


I don't know how big a deal these errors are only that it prevents me from zipping up the mod, so let me know if there no big deal.

------------------
Tread Marks Ladders

IP:

Kevlar
Member
posted June 05, 2002 08:53 PM            
To just clear that up, the master pack is not one pack but two. The client and SSO packs.

[This message has been edited by Kevlar (edited June 06, 2002).]

IP:

Vlad
Member
posted June 05, 2002 08:57 PM            
quote:
Because the stock wonk file has an error

Not exactly fair to call it an error. It's more that ENTegrity has a problem with type names and filenames not matching (I could have sworn that was fixed a while back...).

quote:
The zip you provided also has DarkNovaCruise, ShadowSummoner, Supershadow summoner, are they stand alone weapons themselves? Or are they just parts of the mod?

They're all part of the same mod. ShadowSummoner is the regular weapon. SuperShadowSummoner is the super-rare version that looks exactly the same, but is the "malfunction" version, that produces the 3 ships that hunt everybody on the map. DarkNovaCruise is an offshoot of the SuperShadowSummoner.

IP:

Random Chaos
Member
posted June 06, 2002 01:06 AM            
What they should do is:

If its a type/name mismatch give a warning. Then if there are only warnings, there is no error displayed. If there are errors, those warnings can sometimes help...

IP:

swisher
Member
posted June 06, 2002 11:20 PM            
Yes. Error 0600 is overkill. I'll fix it in the next release. I'll make it a warning. This one goes back to the original vrsion of ENTegrety, beofre I fully understood class/type pairs.

The other errors mention (0402 and 0205) are true errors. Error 0525 is, I believe, a true error. I think I ran some tests and found that Tread Marks wants white space between around the equal sign separating parm from value.

------------------
Swisher - Check out ENTegrety for mods.
BWL/MG

IP: