|
Author Topic:   multiplay schizophreenia (sp)
wolfman
Member
posted January 14, 2003 12:43 AM            
This is a request for help from all of the pc gurus out there. I am having major problems playing in multiplayer - once i get online the controls work fine for a bit then all gets schiz'd. Tank freezes up, keeps going on in same direction or in circles, tank goes forward and the turret goes round and round. Have new keyboard (initially thought the cause was a Dew spill on it the other night), have done a total reinstall of tm, complete virus scan done etc, and I am my wits end lol Game seems to work fine in single play. Any help greatly appreciated. Thanks. JT

IP:

666
Member
posted January 14, 2003 01:53 AM            
very odd...not quite sure...

IP:

Blue n Gold Sue
Member
posted January 14, 2003 03:02 AM            
This happened to me once. Okay about 3 times.
One time, just hitting the space bar a few times reset things (a GoldAnt_Number1 suggestion, which worked).
Another time, I had hit the freelook key by accident and my view was all skewed, with a similar odd tank behaviour. Try looking at your game controls for the keyboard. See if taking off free look from any alternative method that you use is off.
The third time I had let 666 use my pc. He remapped my keyboard. I don't think he will do THAT again, as nothing is worse that wanting to hit the "N" key to look behind you and have NOTHING happen. Good luck Wolfman. Maybe your son remapped it?

IP:

BamZipPow
Member
posted January 14, 2003 03:21 AM            
First double check all yer settings...

Do you have any other proggies running in the background?

Does this happen for single player?

IP:

wolfman
Member
posted January 14, 2003 06:16 AM            
Thanks for the suggestions:
don't think it has been reemapped - guess a possibility but keys work fine in other programs.
game works perfectly fine inn single player
don't use free look etc - i make sure that camera attached to turret used
have tried various key combos to help clear and none work
Any other ideas most appreciated - Thanks.
JT

IP:

=DNX= Matrix
Member
posted January 14, 2003 06:46 AM            
What you are experiencing is called a "ping spike" - its temorarily lagsyou out of the game due to dropped packets of information. Its caused by rerouting hop servers when theres a data overflow at one youre connected to along the connection path. Its a momentary issue that will clear itself up in about 30 seconds... every game has its own way of handling ping spikes too, tm just assumes ur holding down the same keys util the spike has passed.

So dont worry JT, theres nuthin wrong with your TM install.

Some tanks in other games "warp" around because the data you recieve (location of the tank-wise) is vastly different to the last set of co-ordinates the game got - so the game figures TANK IS AT CO-ORDS SET A / TANK IS AT CO-ORDS SET B and so on.... Tm avoids warping effects by tracking your keypresses, so if the last thing u were doing was turning left when the spike hit, youyrtank will continue doing that till ur modem manages to send data to the master (thru the hop servers) selling it somethiong different - to all intents and purposes, the master server for tm still thinks ur holding down the tank rotate key.

IP:

wolfman
Member
posted January 14, 2003 11:44 PM            
Thanks for the info - now I understand. Butttttttttttttttt how can I get it to stop - in the 2 plus years of playin TM online I have never had this prob - or if I did it fixed itself ASAP and did not go on for days. Any further info most appreciated. Thanks JT

IP:

wolfman
Member
posted January 15, 2003 06:56 AM            
Bump - Helllllllllllllllppppppppppppppppp!
Callin all tanks! Callin all tanks! Over. Please JT

IP:

corpse
Member
posted January 15, 2003 08:34 AM            
did you send your old lady out to get your key board?
she got you the one with flowers on it right .
a goofy looking key broard , makes for goofy
game playing.

when it happens to me i ( ALT + K )
it makes it stop

------------------
if you cant dance with the dead , get out of my coffin !

IP:

corpse
Member
posted January 15, 2003 09:17 AM            
DO THE DEW !

IP:

BamZipPow
Member
posted January 15, 2003 03:08 PM            
Couple of things...

Did you install anything new lately? Like DX9?

Try another keyboard on yer machine. If it still does it, try wiping and reinstalling. Yah, I know that's an extreme but if you want to play sometime you have to go to extremes.

IP:

wolfman
Member
posted January 15, 2003 05:50 PM            
I did recently install DX9 and have now uninstalled it as well as reinstalling all the video drivers on the machine. JT

IP:

BamZipPow
Member
posted January 15, 2003 06:13 PM            
Not sure you can uninstall DX9 without ripping the guts out of yer Winderz install. It's best that you reinstall Winderz from scratch with all of yer basic proggies, then make an image (ghost) of yer drive so if you ever muck it up again you'll have a better start than from scratch.

IP:

TM BIO Guest 1
Member
posted January 15, 2003 11:45 PM            
"...without ripping the guts out of yer Winderz install..." i like that expression. rip the guts out!

------------------

IP:

Scrap Metal
Member
posted January 16, 2003 12:38 PM            
CRAP! that thing changed my default name! i think this should fix it though...

------------------
Match in the gas tank, KA-BOOM!

IP:

wolfman
Member
posted January 19, 2003 07:07 PM            
all is well and fine in schizo land. Pc doing fine now. Seems it was somethin related with the cable box. Tech says all the indput etc was great and since it was an old box he replaced it and poof everything fine. Frag you online everybody and thanks for everyone's help. JT

IP: