|
Author Topic:   Upgrade "unknown version" error
xtian
Member
posted May 27, 2002 12:45 PM            
Hey Gang,
I just got a copy of the Treadmarks 1.5.5 CD, and I have been trying to upgrade to 1.6 with no success.

I have downloaded all three upgrades, and all of them tell me that I have an "unknown version" of Treadmarks installed, and refuse to install.

The gang at LDA suggessted I replace the "config.cfg" file (with what?!?), or to try my luck up here with you lovely, intelligent, beautiful and helpful people. ;-)

Anybody got any ideas for how to get the 1.5.5 -> 1.6 updater to recognize my version?

Thanks for the help. Look forward to WASPing you kids soon....!

- Christian
Budapest, Hungary

IP:

Rex R
Member
posted May 27, 2002 01:28 PM            
welcome to the forum. there are a number of topics/threads on this very subject. as I recall the English version (as opposed to US) has proven to be temprimental about upgrading(if you make it to 1.59 you can stop there) fear not I'm sure someone will provide assistance

IP:

-DNX-Ni
Member
posted May 27, 2002 01:30 PM            
quote:
1. install the game V1.5.5
2. then install 1.5.9 (ask Weatherman)
3. move the config file to somewhere you'll find it
4. install v1.6 then
5. move the config file back to it's original loacation and 'Who's ya dadda?!?!'

hope this helps!

PS don't ask weatherman lol! you won't get a rapid response just now! u have all the patches, just follow the instructions
------------------
The Ahn-NI-hilator

[This message has been edited by -DNX-Ni (edited May 27, 2002).]

IP:

Dreamer
Member
posted May 27, 2002 02:25 PM         
http://www.treadmarks.com/download.html

is where you should be able to get a clean and upgradeable config file.

IP:

xtian
Member
posted May 27, 2002 02:49 PM            
Thanks for the fast help!

So I got the new Config file, put it in place, ran the updater, and it told me that "TM.exe" was the wrong version and couldn't be updated.

So I took it out of the folder and ran the updater again.

This time it said that "TMVoodoo.exe" was the wrong version and couldn't be updated.

So I took it out of the folder too, and ran the updater again.

The updater ran fine, and says that it updated all the files.

So I put the TM.exe and TMVoodoo.exe back into the folder and ran TM.

The concern I have is that at the top of the screen it still says I am running "Version 1.5.5 Full" even though the updater says that it fixed everything.

How do I know if the update has actually been successful? Or, alternately, how do I get it to update the TM.exe and TMVoodoo.exe files?

Thanks again for the fast help!
- xtreme
Budapest, Hungary

IP:

SuperUnknown
Administrator
posted May 27, 2002 03:46 PM            
Start the game,go to mulitiplayer,refresh the list and pick anyone of the servers.If you still have the wrong version it won't let you join the game.It will say wrong version.

IP:

xtian
Member
posted May 27, 2002 05:00 PM            
Ok...so the problem gets weirder...

I took SuperUnknown's advice and tried to log into any of the multiplayer servers, and every single one gives me the message "Server Full". I am sure that every single one cannot be full...so how do I interpret this latest twist in the Great TM Upgrade Fiasco?

Rhetorical Question: Does upgrading from the full commercial release version have to be so flipping difficult?!?!?! I have a legal copy, and I downloaded the upgrade from the official website...it's not like I am a pirate trying to get something for free that I don't deserve! <grumble grumble>

- xtreme
Budapest, Hungary

IP:

SuperUnknown
Administrator
posted May 27, 2002 07:30 PM            
Sounds like you have a bad install or something like that.I have never gotten a server full messege before.You might have messed things up when you left out some of the stuff in the update.THe only problems I have ever heard of were fixed when the config file was replaced.
I recommend untinstalling the game,rebooting...install again.Another thing is that you don't have to install each update.You install 1.59 and it will install all updates before that.Then if you still get a error replace the config file like it says and you should be good.Make sure you have the latest drivers for your video card installed and a at least 8.0 directx.Plus make sure your card can support OpenGL content and if so try to update it www.opengl.com glsetup.

IP:

Robo Jaws
Member
posted May 28, 2002 08:28 AM            
Hi xtian,
Welcome to TM
There are cases of the installer not recognising
The UK versions of TM.exe and TMVoodo
Email LDA and get the US versions.
Then to install
Installs 1.55
delete the TM.exe,TMVoodo.exe and Config file
Copy the US exe files
Then run the upgrade patch
copy the new config file
and away you go

------------------
TM Tank drivers licence applied for

IP:

Grind_and_Click
Member
posted May 28, 2002 12:55 PM            
that is whats wrong, thats what happeend to me, u need US tm.exe and tmvoodoo.exe

IP:

xtian
Member
posted May 28, 2002 02:38 PM            
OK, I emailed LDA and asked (very nicely) for the files to be sent to me. I can't believe they will do it, but my phalanges are crossed.

Thanks again for the groovy help!
- xtreme

IP:

xtian
Member
posted May 29, 2002 01:27 PM            
Followup...

...still no reply from LDA. My last question was answered in less than 12 hours.

I think this is not a good sign...

- xtreme
Budapest, Hungary

IP:

SuperUnknown
Administrator
posted May 29, 2002 03:42 PM            
I just emailed you those two files out of my install.Maybe it will work for you.Together they were a little over a meg in size.

IP:

xtian
Member
posted May 30, 2002 04:00 PM            
Most Excellent! I got the files, put them in place of the files in my existing install, and the upgrade went without a hitch. (Ran the 1.55->1.6 updater.)

The problem is that I cannot see any servers now. My internet connection is good (after all, I wrote this, right?), and I have updated the Master Port from 12399 to 12499. (Interesting side note: the Master Port number was already set correctly when I went in to change it!)

So I can see no Internet Games at all, and I get no useful error messages. It begins without any Master Server address, so it connects to the website and gets the Master Server address. Then it queries the net (I assume), and comes back with No Servers.

Anybody have any other ideas?

Thanks,
- xtreme

IP:

Sailor
Administrator
posted May 30, 2002 04:03 PM            
When it gets the new IP for the master do you click on the refresh internet toward the bottom. You would have to do that to cause the master server to list the available servers. Simple but required.

------------------
May you always have a following Sea and the comfort of those you hold nearest to your heart.
TMMaps

IP:

xtian
Member
posted May 30, 2002 04:49 PM            
Yeah, I Refresh Internet, and it connects to the Web Server, gets the Master Server IP, searches for Internet Games, and then gives me the error "Not Connected".

And yet...here I am "connected". (I have a cable modem connection that keeps me online 24/7, so there is no chance of forgetting to log in or connect.)

Note: The Demo version works fine and sees network games. Just my newly upgraded 1.6.0 doesn't see any net games.

Other ideas? Keep 'em coming!
- xtreme

IP:

Random Chaos
Member
posted May 30, 2002 05:33 PM            
check that the master server is set to:
206.222.78.139
(its port 12499, but I don't think that TM needs unless its a nonstandard port used)

Also, grab this http://www.treadmarks.com/TMMasterClient.exe and check to make sure that you can reach the master server as listed above (you'll probably have to enter a new server IP for it)

TM Master Client can cause problems if left on too long though...its only a beta and unlikely to get any more attention.

[This message has been edited by Random Chaos (edited May 30, 2002).]

IP:

SuperUnknown
Administrator
posted May 30, 2002 10:32 PM            
Thats because I sent you the actual files from my TM installation.That I had already updraded and changed the master IP.Maybe I can send you the 1.5 tm and voodoo .exe's if you still have problems.Change the IP to the one listed on the tm server page and you should be running fine.
Send you the files from the CD(1.5)that is.

[This message has been edited by SuperUnknown (edited May 31, 2002).]

IP:

xtian
Member
posted June 01, 2002 03:40 PM            
OK, I changed the Master Server IP address on the "select a server" screen in TM, and it still looks, finds nothing, and then says "Not Connected".

I am beginning to think that maybe my ISP has blocked access to the Master Server IP address. I am going to check with them.

I am also going to download the TMMasterClient.exe and see if that sheds any light on the problem.

Thanks again for all the help,
- xtreme

IP:

xtian
Member
posted June 01, 2002 03:51 PM            
Update: The TMMasterClient application sees the Internet games that are currently running. I can select them and view their stats.

BUT...if I click the "Connect to game" button, it launches my version of TM into a SINGLE GAME version of the last map that I played! It does not connect me to the server game that I have selected.

Bizarreness abounds...

- xtreme

IP:

SuperUnknown
Administrator
posted June 01, 2002 04:22 PM            
I say completely uninstall the game.Reinstall 1.5 off of the CD.Then I'll send you the two exe's..US version off of my cd.Replace the voodoo and tm exe with the ones I send you.Then you should be able to updrade to 1.6 with no problems.I sent you those two exe's out of my installation so that might be why it is running strange.
Just tell me go for it and I'll send you the fresh,1.5 exe's.

IP: