|
Author Topic:   recovery from mod pack overload ???
synack
Member
posted August 23, 2001 07:10 PM         
I know there are a few of you out there who have experienced this after downloading TOO many mod packs. A random sound file begins to perpetually repeat itself during game play, driving you nuts. I've been living with that "feature" for a few weeks.

I've read that it may be due to overloading the TM infrastructure with too many mods.

Does anyone have insight/experience with how best to uninstall/reinstall to the current game level, with minimum number of steps?

I thought I'd probe the collective consciousness before blindly stiking out alone, hopefully to avoid known minefields.

IP:

JVortex
Member
posted August 23, 2001 10:57 PM            
the problem may be centralized in the voyager and warbird tanks. they both utilize custom multi kill sound events, a feature TM is supposed to support, but doesnt really. the feature works great until theres more and more mods installed... this is the reason that i removed those sound events from the Kasplattt server.

i would suggest first removing the multi-kill lines from the tank ent files before you go and start removing favorite mods .
open up the voyager and warbird tank files and comment out the MultiKillSound lines in each one. this might fix your problem.

if you would prefer to leave those sounds in (like i did) you can remove the ent files to weapons that you dont like or dont use very often, but LEAVE the bmp's and models for those weapons in their respective folders. that way they will still be useable online. the "missing" ent files will synch themselves when u log into the server.

hope that helps

------------------
Let the rocks roll and the battle commence. BZ The RPG. Check out the site! Loads of Tread Marks support and AddOns. (Under Heavy Construction) The non-TM areas of the site have been resurrected!


IP:

Rex R
Member
posted August 24, 2001 01:59 AM            
I suspect that this 'feature' is related to having to many 'vox' files as I have encountered it before the advent of the 'starships'.

IP:

Dreamer
Member
posted August 24, 2001 02:53 AM         
We really have to get those mod handler progs done, I know, but time's a scarce resource these days and I've got three projects running at the same time...

IP:

synack
Member
posted August 24, 2001 05:03 PM         
Thanks for the suggestions, guys. I'll start out slowly. JV, I finally found .ent files for warbird and voyager in this folder.

C:\Program Files\TreadMarks\Addons\entities\RaceTank

Does that look like the right place to be commenting out the multi-kill lines? (Please forgive my ignorance; I'm not a modder.)

I'll give it a try and see what happens. Just for the record, my echo problem did begin after loading these two mods. But maybe I was already near exceeding an unknown threshold when I added them.

[This message has been edited by synack (edited August 24, 2001).]

IP:

synack
Member
posted August 24, 2001 05:23 PM         
ok, that didn't help. Still wonder if I have the correct file-spec JV.

I'll take baby steps until I see improvement.

IP:

JVortex
Member
posted August 24, 2001 11:05 PM            
ok, yes those were the right files. as far as i can tell there is an unknown limit to how many mods TM can support before it starts to get glitchy. ive noticed that in REALLY modded addon folders sometimes not only sound ent's will suffer but a few explo sprites forget to appear as well. its odd.

your best bet is to start maintaining multiple addon folders. the problem seems to be more pronounced when playing online. i really suggest having 2 addon folders. 1 with just everything in it for playing offline and another with very few entity files in it and leaving all models, sounds and bmp's for online play. since i did that i havent had that problem at all.

IP:

Rex R
Member
posted August 25, 2001 04:06 AM            
to my knowledge the file spec is correct. you might also comment out namesound on the addon tanks. nother set of vox files is connected to the 'midnite' missile. HTH

IP:

SuperUnknown
Administrator
posted August 25, 2001 04:33 AM            
I've starting hearing sounds in my game too.Like weapon sounds that constantly make firing noises when nothing is visibly there(machine gun noises that don't stop and are centalized in a small area).And also spawn point weapons sometime leave a ghost behind.You can still see the weapon after you pick it up.I've only noticed it when I'm running the TM version that holds my mods.Could be a server glich though.

------------------
Mod Packs,Weekly Polls,Links, and Other Files...Storage/Download


IP:

synack
Member
posted August 25, 2001 06:53 PM         
rex, I commented out namesound on warbird and voyager as my next step. It hasn't had any obvious effect.

I've copied all the mod packs, upgrades and various config files to a seperate directory in preparation for a full uninstall/reinstall, but I'm waiting until I've got a good bit of time to dedicate to it before I push the button.

I'm trying to post relevant information so that others who encounter this in the future might have their frustration level minimized.

IP: