|
Author Topic:   New nguk server pack AND warbird released
JVortex
Member
posted June 25, 2001 08:55 PM            
ok peoples, there is a brand new nguk Kasplattt pack out and the warbird is also out for release today.

the nguk pack is a NEW pack to replace the old one and is not an upgrade. as of this minute the new pack is not being used on nguk, but i will post here when it gets installed. i have emailed malice and he is normally very prompt on installing the packs. im not posting a direct link here for the new pack because there is some special info i would like people to be aware of on my site, please go to www.bzrpg.com and enter the tread marks area, then hit the nguk Server page to get the new pack. here is whats in it:
240mm
bomb lobber
CNuke
hyper chip
mortar
particle driver
plasma shovel
plasma shield
chaos
tornado
fake tank
paper airplane
shatter missile
spirit bomb
random weapon
modified sabot
aero
dunner
sith
recon
spade
voyager
warbird
new Question mark model for rand weapon

short version of special info:if you run multiple packs delete old nguk server pack and replace with new one. if you run a single addon server directory then when extracting new pack let it replace any files that it says it needs to. these are mostly all updated weapons and tanks.

--------
the warbird has also been released. note that its in the new nguk pack, so you dont need to download it seperate if you dont want to. but for whatever reasons you may have, the warbird can be downloaded here: http://server2049.virtualave.net/jvortex/dloads/TM/tanks/Warbird.zip

-------

if there are any problems or comments go ahead and email me at JVortex@bzrpg.com or just reply here. that should do it! im in a rush so later all!

------------------
Let the rocks roll and the battle commence. BZ The RPG. Check out the site! Loads of Tread Marks support and AddOns. (Under Heavy Construction) The non-TM areas of the site have been resurrected!

IP:

JVortex
Member
posted June 25, 2001 11:59 PM            
no word yet from malice on getting the new pack up on Kasplattt. so the Warbird and Voyager ARE NOT on kasplattt yet. just so yous all knows

IP:

Dreamer
Member
posted June 26, 2001 02:58 AM         
and the black widow? where's that? hmm?

IP:

Rex R
Member
posted June 26, 2001 07:32 AM            
JV; found some errors in the server pak. total of 3 none showstoppers. sent you a list and corrected ent files to your email box. have fun

IP:

Vlad
Member
posted June 26, 2001 09:07 AM            
Just so everybody knows, the new server pack is installed on the Kasplatt server!

I see much usage of the Voyager and Warbird in the near future...

IP:

JVortex
Member
posted June 26, 2001 01:20 PM            
oops, sorry Dreamer, forgot that one . well there are, as Rex said (thank you Rex), a couple small errors in the pack. surprisingly most were by the original authors, just stuff that never got caught. so im putting together an upgrade pack. ill shove the widow in there for ya!

upgrade pack will be out in a day or 2 (im gonna wait on Vlads weapons). any one have any requests?

IP:

LordDrow
Member
posted June 28, 2001 10:54 PM            
I have one new tank available within the week pending detailing and image mapping. Hope to have at least 2 to 3 more available over the next few weeks. Let me know if you are interested. If you want a review of the beta, check with Lord Byron or drop me an e-mail and I will try to get you hooked up.
Any good image mapper that would like to skin a tank or 2 drop me a line as well.

LordDrow

IP:

JVortex
Member
posted June 29, 2001 12:23 AM            
im all up for testing out a new tank. doubt i would have time to make a decent skin for it tho.

just so everyone knows the errors in the splatpack are being dealt with. im making an upgrade pack. some errors are out of old files, some are new errors. about 90% of the problems on the server have been fixed (and new weaponry added as well) (in the not yet released update) but im waiting on releasing the pack til the thing is 99% bug free. so dont fret, help is on the way!

------------------
Let the rocks roll and the battle commence. BZ The RPG. Check out the site! Loads of Tread Marks support and AddOns. (Under Heavy Construction) The non-TM areas of the site have been resurrected!

IP:

JVortex
Member
posted June 30, 2001 01:16 AM            
i thought i would just continue this post instead of making a new topic.

people (including myself) have been reporting problems with the new splatpack and/ or voyager. im pretty sure that ive come to the conclusion that its not really the fault of either of them, but a fault in TM itself.

the problem has been messed up engine sounds. mainly TM confusing engine wave's and instead playing a vox sound in its place. after a lot of testing and messing with my own files (which by the way ALL entity files are 100% correct on what sound they are trying to play) and getting some info from other people who have had this problem i think i finally have the answer (i hope).

there is a practical limit to how many addon mods that TM can handle before it gets confused. most games have an addon limit to how many whatevers they can use at any one time, looks like TM has such a limit as well. i dont think its a matter of how many seperate mods are installed, but more a matter of how many seperate files are in there for TM to weed thru.

the problem can occur in single player but is much more common in multiplayer.

the best fix so far that has worked every time is to limit the number of files (and thus mods) you have in your addon folder. chances are that those of you who use seperate addon folders for different servers havent ran into this problem, but those who use 1 single addon folder for everything have probably heard this.

it may be a physical computer limit tho, something like not enough RAM or too slo of a CPU to process all the ent's as fast as TM wants it to, i dont know there.

the fix?
so far the fix that has worked 100% is to make a new addon folder with just a select few mods in it. as an example the new splatpack was doing this to me when it was within my main big addons folder. i then removed it from that folder and instead installed the new splatpack to its own addon folder by renaming my old one to something else. the engine sounds havent screwed up on me since then.

i also suggested to a couple other people who were having the problem to do the same thing and they said it fixed it just having a "smaller" folder. i assume it hasnt screwed up on them since then.

with the amount of different mods comming out sheer numbers appear to be making TM quite unhappy.

this also coule in theory be an error in the 1.6 patch, tho i doubt it. has anyone heard odd engine sounds from their tanks who is running v1.59?

any input would be handy on this as id like to track down the problem. any posts on weather youve heard it or not heard the strangness would be appreciated.

[yes, another long winded post by JV ]

IP:

Rex R
Member
posted June 30, 2001 03:02 AM            
the other problem with having a humungus(x-lg) addons folder is that it makes for slower load times. now some of you folks with nice new speedy comps might not have noticed this but, as for me with my poor 'bused P2 400 the loadtimes with the old NG(uk) server pack was 2 minutes and w/o 65 sec. this is why I was having problems logging onto skan's ddm server. once I removed the 570+ files addons folder the problem went away. of course your milage may vary

IP:

Vlad
Member
posted June 30, 2001 09:14 AM            
Well, I experienced the "engine sound" problem before ("Aero, aero, aero, aero".. grr), and the only thing I had in the addons folder was the current splatpack.

IP:

TurdHeart
Member
posted June 30, 2001 09:43 AM            
Yup - same here - Splatttpack only...
"You've lost the lead You've lost the lead You've lost the lead You've lost the lead You've lost the lead You've lost the lead You've lost the lead....". Well, you get the idea. Somehow I finished a whole game with that blaring.

Is the high-friction intentional on Kasplattt? I generally prefer the original settings for higher turning speeds, but it's not a big deal.

IP:

Dreamer
Member
posted June 30, 2001 09:49 AM         
Could this be a numeric overflow problem? Maybe TM uses some single-byte algorithms where it shouldn't...
Tom?

IP:

JVortex
Member
posted June 30, 2001 11:47 AM            
impressive TH, i wouldnt have made it thru a match like that! a true fan there, hehe. and ya the friction was set that way on purpose. mainly for those people who dont think a tank should powerslide quite so easily.

the problem with the splatpack appears to be number of files, not number of mods. i went thru and did some counting and most older weapons had like 5 or so seperate files to them, some up to like 10 (including all ent's and wav's and stuff). newer mods are getting more and more complex and having more individual files to them.

so older weapon packs (and older weapons in general) having less files aparently get along better with TM when it goes and builds its little temporary data base of files. i tested this by removing all ent files from my addons directory and then connected to kasplattt and let TM just grab all the ent's fresh. didnt have any problems at all. only did that twice tho, so it wasnt a really complete test.

has anyone with a high end computer (over 900Mhz CPU or over 300 RAM) ran into this sound problem? maybe it has something to do with that.

im not enough of a programmer to figure out anything abo0ut numeric overflow stuff

IP:

synack
Member
posted June 30, 2001 12:03 PM         
You've lost the lead ... you've lost the lead ...


LOL TurdHeart! The same thing happened to me. I thought TM was possessed or perhaps trying to taunt me into a breakdown!

IP:

Nemzad
Member
posted June 30, 2001 12:46 PM         
JV I have noticed that when I do not have any sound trouble that the voyager is not in use by any AI'S or humans but as soon as another player or myself change to the voyager the sound problems start.
I'll try the multiple addons folders later this week. I'll be going out of town so I'll cya's mid week.

IP:

JVortex
Member
posted June 30, 2001 01:07 PM            
ya nem, the problem really seems to spike with either voyager or warbird running, probably due to the fact that they use more ent files together than 10 normal tanks . and its the tank files where the messed up sounds are comming from. maybe TM has a hard time dealing with X amount of tank ent's? but it doesnt mind excessive weapon ent's?

IP:

=DNX= Matrix
Member
posted July 01, 2001 01:18 AM            
Lord Drow, id be happy to skin it for you - send me the model and a rough descript of what you want.

if u have it up online as a zip ill link straight in from the DMF
www.deathmatch-federation.com

same goes for any mods that stay online.

cheers lads.

IP:

LordDrow
Member
posted July 02, 2001 05:01 PM            
Looks like matrix replied to a post of mine in the wrong forum...heheheheh.
Anyhow, yes, I am running Athlon TBird 1Ghz, 256 MB RAM and I still get the sound problems. I think we may have gotten some of that problem figured out though. Sound errors only seem to happen when I come into a game that is mixed Fed and Stock tanks or if someone switches from a stock tank to a Fed tank in-game. Switching from Fed tanks to stock tanks also seems to cause the problem. Games that are made up entirely of stock or fed tanks don't seem to be subject to this bug....errr feature..... hehehehe


LD

IP:

JVortex
Member
posted July 02, 2001 05:22 PM            
ya, so far looks like its a problem with tanks having too many ent files to them. maybe TM creates a different temp file for tanks and one for weapons. for whatever reason TM seems to complain with tanks that have excessive ent files. the rest of the pack is uneffected.

IP:

Dreamer
Member
posted July 02, 2001 05:57 PM         
Dunno, maybe others can give feedback on this, too...

I think the Spade and SpiPlane tanks are a tad too powerful for normal servers...
Maybe they should not be included in the next version of the pack...

IP:

Vlad
Member
posted July 02, 2001 08:31 PM            
I believe that the spyplane is already gone from the current pack.

Personally, I've always found Spade to flip way too much...

IP: