|
Author Topic:   Lockup at shutdown
Sailor
Administrator
posted January 29, 2001 08:14 PM            
Still having a problem with the lockup at shutdown of 1.5.9 with all the latest modifications installed. When I quit out of TM it blanks out the upper left of my desktop and continues to play music. I have to press CTRL+ALT+DEL one or more times and click on END TASK in the list to get out of TM. This is bothersome and wastes time when leaving the game. My configuration is as follows:

Dell Dimension XPS 500
NVIDIA Riva TNT
Windows ME
DirectX 7x
Turtle Beach Sound Card

I hope this helps, but you can e-mail me if you need any further info.
Please look into this and resolve this exiting problem. It did not happen in the 1.5 version and has only been a problem since the patches have been out and I have applied them. Currently I have the original version, 1.5 and 1.5.9 on my system. The original does not do this still and 1.5 does not do this, but 1.5.9 continues to do it. So HHHHEEEEEELLLLLLLLPPPPPPPP!!!!!!!!!! I like this game too much to have this as a continuing problem.

------------------
Pass the salt - it's time to go to sea. Clan TC

IP:

LDATom
Administrator
posted January 30, 2001 12:37 AM            
Very odd ... I'll see if I can find something that might be causing it, but none of our machines exhibit the problem currently so it will take me some time.

Tom

IP:

swisher
Member
posted January 30, 2001 09:46 AM            
Sailor,

A few basic questions:

1. Are you in normal, full screen mode when you play (i.e., you do not see the Windows task bar)?

2. Do you exit normally. That is, press ESC, click Stop Game, and then click Quit?

Perhaps try:

If you do play full screen, press F8 to toggle to windowed view. Start and exit a game normally. ALSO start and exit this windowed game by clicking the window "X" (close) in the upper right of window. See if the problem is still there.

If you play in windowed mode, press F8 to toggle to full screen. Start and exit a game normally.

I'm just wondering if it occurs in both full screen and windowed mode; this may help Tom.

------------------
Swisher
BWL/MG

IP:

swisher
Member
posted January 30, 2001 09:52 AM            
A few more thoughts.

Disable music.

Disable Joystick.

Now, start Tread Marks in all of it's different initial Gfx Configurations, start a game, and exit normally (fast, pretty, normal, Godly).

Idea being that a process of elimination may eventually isolate the problem.

------------------
Swisher
BWL/MG

IP:

JVortex
Member
posted January 30, 2001 12:42 PM            
Here is a fix for you.

I was having almost that exact same problem myself after reformatting my hard drive. Although on exit I didnt get music, just blackness in the top left corner. This evil blackness also just happened to be the same size as whatever the resolution of the program i was running was set at (so normally an 800 x 600 square). Coincidence? I thought not.

For me this problem only ocurred when exiting the game normally from playing in full screen mode. Exiting from windowed mode and/ or alt+tab'ing back to windows to close from right clicking the taskbar would both work fine. This same thing happened with a few other games and a couple rendering programs as well. I finally discovered the what all these different applications and games had in common:

OpenGL...

Once I realized that everything that was leaving the evil blackness behind on exit was OpenGL based I took off to www.opengl.org and from there found GLSetup.exe. It can be found here: http://webdeploy.glsetup.com/webdeploy.118/glsetup.exe . Read this page first though as it tells you which video cards this program supports: http://www.opengl.org/users/downloads/index.html?download .

As far as I could tell (which granted I didnt read as much as I should have, but I have GoBack, so I can be a bit sloppy) this prog works by scanning your system and updating various drivers including your video drivers and so forth. So make sure that you are online when running it and don't have anything else major running. Personally I would also suggest having some means of backing up your system before doing this, just because I'm paranoid that way. Personally I use GoBack even though I run Winders ME and have System Restore on here, I cant stand System Restore...

Hope this helps you out.

------------------
Let the rocks roll and the battle commence. BZ The RPG. Check out the site!!

IP:

Sailor
Administrator
posted January 30, 2001 08:43 PM            
Thanks for the replies. LDATom thanks for looking into the problem. Swisher thanks for the concern and suggestions - good ideas. JVortex thanks for your suggestions and the URLs. The problem now appears to be fixed. I downloaded the latest NVIDIA TNT drivers for my system and all seems to now be working correctly. It even fixed my option to select 1024 x 768 for the game - the same as my desktop - which did not work before. I did not need to update the OpenGL drivers, but checked that option out also. Thanks again for all the suggestions and information. It is very good to see the help one can obtain when having a problem and the depth to which that assistance goes.

------------------
Pass the salt - it's time to go to sea. Clan TC

IP:

GoldAnt_Number1
Member
posted February 01, 2001 11:08 PM            
I got the same problem toooooo. Is it TM? or my cpu still don understand. Im gonna go try what u tried but how come exiting always worked before.....................................

------------------
Can't forget those invisible smileys at the bottem now can we

IP:

GoldAnt_Number1
Member
posted February 01, 2001 11:10 PM            
Oops and also nowe my cpu when shutting down itself comes right to where it should shut down and go into sleep mode and turn off................. except it stays there with a bright black screen.?????

------------------
Can't forget those invisible smileys at the bottem now can we

IP:

Sailor
Administrator
posted February 04, 2001 07:39 PM            
GoldAnt my problem was with the older NVIDIA driver. If you are having the same problem it could be one of two things possibly. It could be your video card driver or the OpenGL drivers. If you are up to date on your video drivers then try the OpenGL drivers that JVortex referred to in his post they look like a positive step in the right direction. Let us know if you work it out or maybe we can point you in some other direction. Hope this helps.

IP:

Cell
Member
posted February 04, 2001 08:11 PM         
Goldant, you'll need to provide the correct information about your system, if you want to receive any useful information that may help diagnose the problem.
We have nothing remotely usefull to even begin!

IP:

GoldAnt_Number1
Member
posted February 04, 2001 09:03 PM            
k, well when TM starts I click open3dhardware i have no clue what my driver is but it must be pretty new cause my cpu is

------------------
Can't forget those invisible smileys at the bottem now can we

IP:

Cell
Member
posted February 04, 2001 09:40 PM         
The CPU is the Central Processor Unit....not the big white box under the desk!
Maybe I didn't make myself clear...We need useful information in order to help you, like OS, Video card chip, sound, chipset, for crissakes!

IP: