|
Author Topic:   Internet play problems
Ralpho
New Member
posted January 23, 2000 07:18 PM            
Hello everyone, forgive me if I sound stupid, but i can't get internet play to work. When I try to join a server, it loads, but doesn't display my tank or let me move. I'm assuming this is because I have an ISDN router rather than a local internet connection. I wondering if there is a way to bypass this? or is this even my problem? Not all games have problems with my router. Starseige Tribes works great, as does Mplayer. However, Battle.net and Diablo does not. Does Treadmarks use UDP for internet play or TCP-IP? Does anypone know how to configure the router to be compatible? Thanks a lot.

(By the way: I saw other messages begging for a vertical aim feature. I am strongly opposed ot the addition of vertical aiming. If it were added, people would sit still on top of hills and take potshots at each other trying to get their ballistics right like in the days of Scorched Earth and Artillery. The lack of vertical aim is very important because it forces people to MOVE!!!)


BTW I HAVE FULL VERSION

[This message has been edited by Ralpho (edited January 23, 2000).]

IP:

Hawk
Member
posted January 23, 2000 09:55 PM            
Question: Do you have the full version or the demo?

IP:

Random Chaos (TC)
Member
posted January 23, 2000 10:53 PM            
TM uses UDP for play, but what you are discribing is what seems to be happening when a full version client joins a demo version with a tank not supported in the demo.

------------------
Random Chaos
Site admin for http://treadmarks.3d-unlimited.com
Member of Clan Temporal Chaos
neym@rpi.edu

IP:

Ralpho
New Member
posted January 23, 2000 11:40 PM            
I have full version

IP:

kenny
Member
posted January 23, 2000 11:48 PM            
i had a similar problem. make sure you have DNS setup correctly. if you are accesing the internet though a proxy server i can help you.

ok assuming from what you said in your post i assume that you have the default router gateway setup. you may not however.

check your settings in the network control pannel TCP/IP settings.

if you dont want to spam this board with your problems dont be affraid to email me dude. i get roughly 50 emails a day and all i do is sit on my computer and do nothing all day so its cool to help people :-)

IP:

kenny
Member
posted January 23, 2000 11:53 PM            
correct me if i am wrong but you cant get UDP to go though without TCP/IP to be configured correctly. TCP/IP is THE internet protocol, your info cant be routed though the routers to the destination without it. i know you can do it with bridges and MAC addresses but the internet aint made up of bridges :-P

IP:

Random Chaos (TC)
Member
posted January 24, 2000 12:25 AM            
I think UDP is basically an overlay of TCP/IP, but I know it doesn't require the ACK packets that TCP/IP uses (since when our firewall started to inexpicitly block ACK packets, everything that used UDP still worked)...

IP:

Kaeto
Member
posted January 24, 2000 05:46 PM            
It's gotta be the Full client/demo server thing... TM uses the same architecture to connect as to run the game (if I remember Seumas right...), so he must be getting in, but having and invisible tank...

IP: