|
Author Topic:   Voodoo3 irregularity
Awerthan
unregistered
posted October 20, 1999 05:26 PM           
Ummm... guys, is there any particular reason that the Treadmarks test v. 2.1 runs better in a window with my Voodoo3 than it runs full screen? Don't you think that's just a tad bit odd?

IP:

LDA Seumas
unregistered
posted October 20, 1999 08:39 PM           
That is odd. On our Voodoo 3 it runs much better in full screen (20-30 fps) than in a window (5 fps).

Perhaps you're trying to run full screen in 32-bit color, which the Voodoo 3 can't accelerate?

Have you tried using GLSetup to install drivers?

------------------
-- Seumas McNally, Lead Programmer, Longbow Digital Arts

IP:

Awerthan
unregistered
posted October 22, 1999 04:54 AM           
No, everything is always set to 16 bit colour due to the lack of external 32 bit support. I just don't get it, I was wondering why the hell it did run better. I haven't tried GLsetup, no, but I did install the latest drivers from the 3dfx website - 4.11.01.1204.
It runs at a good 30 frames a second in windowed mode at 640 (occasionally drops, but what the hell, it's to be expected) and keeps at around 20 in 1024 mode. Frankly, I was surprised that it even WORKED in windowed mode, since 3dfx cards generally dislike any type of windowed mode, be it OpenGL or whatnot (and to my knowledge Glide doesn't support windowed mode).
You got me, man. Just thought I'd let you guys know. This is with a view distance of 500 and a tris setting of around 5000. 25% smoke. Who knows.

IP:

Akuma the Lounge Lizzard
Member
posted October 24, 1999 02:39 PM         
I have the same setup, 500 view distance, tris setting of around 5000, and 25% smoke. And a screen setting of 640 x 480. And it runs fairly slower than in window. I hvae a Voodoo3 2000.

IP:

LDA Seumas
unregistered
posted October 28, 1999 12:42 AM           
Akuma,

Meaning it runs faster in Windowed mode for you too? Or did you mean to say it runs faster in full screen mode?

------------------
-- Seumas McNally, Lead Programmer, Longbow Digital Arts

IP:

Akuma the Lounge Lizzard
Member
posted October 31, 1999 04:00 PM         
it runs slower in full screen. there is a fair amount of noticable lag/jittering. And I've d/l the latest drivers & optomized the settings for the video card.

IP:

the_thing
New Member
posted October 31, 1999 04:39 PM            
I own a banshee,
I haven't check the fps at which I play, that is not that high anyway

The game goes well in windowed mode, maybe better, I haven't checked.

I'd just say that when you alt-tab, sometimes 2 windows appear. I can guess that the second window is the DirectDraw window, but I would recommend to check to destroy it when not needed. (Or at least use another name).

By the way I am making my own opengl window wrapper that should be more robust that the one given on the LDA site, but mine is still not finished

-------------------

Some bugs I found:
Not a "bug", but on 32 megs of ram, the game is quite hard to play on the net, since I get timed out even before joining the game! (It trashes a lot on only 32 megs of ram). I played with 48 megs and it was ok (still thrashing a lot) but I was able to join a game.
Maybe you could redo the loading of the data in a way that it thrashes a little less?
Maybe only when the games detect that the computer only have 32 megs of ram.

Second, two time I got it to play on the net, my turret was turning around all the time without any way to stop it. The turret's keys were unresponsive.

Third, you should make the menu in a game play a little more opaque, since sometimes when the game play screen is too light and the user bring up the menu, the menu is almost unreadable.

Oh I forgot
Sometimes it crashes when switching video mode. Especially the second time i start the game on one window session.

Sorry for my english. I could write in french but I guess I wouldn't get any answer

M-A

[This message has been edited by the_thing (edited October 31, 1999).]

IP:

Hawk
Member
posted November 17, 1999 09:13 PM            
I had an sort of unrelated problem with my Voodoo 3 2000 card when I downloaded TM 2.1...It didn't work at all. When you'd initialize Hardware Mode, it would make the desktop screen appear to be in 640X480 mode. Then the screen would blank, then come back with a Fatal Error message and the computer would lock up. Solution: I downloaded the latest V3 drivers (Beta 2.1 Release) from 3DFX's website. Now it works perfectly. Nice work on the game, LDA!

------------------
I don't suffer from insanity...I enjoy every minute of it

IP:

Hawk
Member
posted November 17, 1999 09:17 PM            
Sorry, forgot to tell the problematic DLL...

opengl32.dll

------------------
I don't suffer from insanity...I enjoy every minute of it

IP: